Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Oct 26, 2006, 5:37 PM   #1
Junior Member
Join Date: Oct 2006
Posts: 1

I'm hoping you guys will be able to help.. I have taken some photo's using my fuji finepix camera and a 1gb Fuji memory card.

The photo's were clearly on the card (I viewed them on the camera) and I also looked at them on the PC. I didn't save them..

When I looked the next day I got an 'initalization error' and now I can't read the card either on my pc or my camera. Are my photo's lost forever? What has happened.

I tried my spare 1gb card too but that has the same message....

Is there a way to rescue my pictures?

Thank you for your help.
cfg is offline   Reply With Quote
Sponsored Links
Old Oct 26, 2006, 6:56 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,367

Are you using a card reader to try and read the card, or are you just trying to use a USB connection from your PC to your camera to view what's on the cards?

JimC is offline   Reply With Quote
Old Oct 27, 2006, 8:28 AM   #3
Join Date: Nov 2003
Posts: 68

Most of the card readers will not "see" the 1GB" Xd cards. What Fuji are you using? The S9000 has a warning regarding connection of the USB and removing this connection without first doing something else. So to be vague but check your camera literature for USB connection issues.
bill soper is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:03 PM.