Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old May 1, 2007, 7:56 PM   #1
Junior Member
Join Date: May 2007
Posts: 2

I'v had this camera for a few years and got this error message a few times but it always went away after turning on and off. This time it here to stay. Do I need this camera services or is there something I can do to fix it myself?

Any feedback would be appreciated.
jude351 is offline   Reply With Quote
Sponsored Links
Old May 1, 2007, 11:08 PM   #2
Senior Member
Join Date: May 2005
Posts: 1,058

This isn't meant to be anything negative about you. But the fact that you have to ask the question indicates that you probably need to send the camera to a service center. You probably are not like me. But if I cannot fix something with duct tape or WD 40 then I am in big trouble.

Unfortunately, I don't believe the camera manufacturers intend for these cameras to last for decades like some of the old film cameras did. Digital cameras are pretty much a disposable item. If it needs to be repaired then it's probably cheaper to get a new one. Probably isn't what you want to hear, but that is my opinion.
jphess is offline   Reply With Quote
Old Jan 22, 2008, 8:51 AM   #3
Junior Member
Join Date: Jan 2008
Posts: 1

I had same thing. I took camera to bits and still didn't work. Then one day just before throwing it in the bin with batteries in and lens extended, I grabbed the outer ring (bigger part of lens near the body) and pulled it out a little further. I think there was a slight click then the red light turned green and everything was back to normal. Maybe I was lucky,but its worth a try because it definitely worked for me. Cheers John
johnmcna is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:52 PM.