Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Apr 10, 2006, 9:19 AM   #21
Junior Member
Join Date: Apr 2006
Posts: 1

Same stuff happened to me 2 weeks ago. I was inserting a battery and I think by accident pressed on power at the same time.. lens went open and got stuck.

its now says Zoom error when you turn it on. dont know what to do, I know its not worth fixing it because Fuji doesnt want to tell me an estimate repair value it only says wont be more then 200 euro. thats no good. I love the camera bought it used and im sure the previous owner have dropped it on the ground some time .

sometimes you feel like

SSLStudio is offline   Reply With Quote
Old Apr 23, 2006, 8:00 PM   #22
Junior Member
Join Date: Apr 2006
Posts: 1

To All F601z Owners

I see many of you are having problems, I wish I can provide help, but I'm bringing more problem !

I've expereinced pretty much every problem mentioned in my F601z. I purchased mine 2nd hand onebay. I sensed therewas trouble from the beginning with the unexpected freezings.When the camera was operating, it took extraordinary pictures and short videos. The freezings as described by others where managed. I didn't take too many photos at the same time. As soon as the camera was idle, I'd shut it off (to avoid freezing).

I don't know if this is a cause, my last action with the camera was, I took the smart media card out and placed inmy card reader, downloaded the images, then I deleted the images using the card reader (1st time doing this with the card reader). I placed back the SM into the camera, powered up and nothing starts on the camera. Only the green light next to the viewer is on and nothing else, it's just frozen. Now, even doing the sure startup, i.e. removing the battery and SM for 15 minutes then reinstall the battery (no SM). The camera will not startup at all, all it gives is the steady green light.

It looks more deader than ever!

Any suggestions


stan_lee_514 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:54 AM.