Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Jul 10, 2007, 12:42 AM   #1
Senior Member
toshi43's Avatar
Join Date: Oct 2005
Location: Vernon BC Canada
Posts: 1,618

Doesanyone out there have any experienceusing an external flash on a Fuji S9000 or S9100.? The camera's hot shoe looks like the generic type, so will any non-dedicated flash work? I'd also like to know if a non-dedicated flash can be used toset offa slave flash, and if trigger voltages are an issue.

Thanks in advance.
toshi43 is offline   Reply With Quote
Sponsored Links
Old Jul 10, 2007, 9:28 AM   #2
Senior Member
Join Date: May 2005
Posts: 1,058

Trigger voltage can be an issue. That is why some of the older Vivitar 283 flash units are not recommended. It seems to me that I read somewhere that you cannot use of Irish that has a trigger voltage higher than 300 V or whatever the unit of measure is. A lot of people have recommended the Sunpak 383. I inquired to Fuji at one time about a flash for my 9000. They answered that I can use just about any portable flash that is available, but that some dedicated flash units would not work. I have a Quantaray 7500 that has a Pentax dedicated module on it. That module has a switch position for ordinary auto flash, and it works fine with my camera. There is not a dedicated flash for this camera. I think you can use a non-dedicated flash to trigger other slaves as long as the flash doesn't fire the preflash that some units do. At least that is what I seem to recall reading from other comments.
jphess is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:32 PM.