Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Nov 18, 2007, 10:38 AM   #1
Senior Member
fofa's Avatar
Join Date: Oct 2005
Posts: 547

OK, so I just used my S5200 a couple days before. Noticed the Alk. batteries were getting low, but still had enough umph to take the few flash shots I needed of the girls going to homecoming dance.
Turn it on, nothing.
Grab my rechargable batteries, power it up, nothing.
Hummm, I thought those were recharged.
Grab some more Alk. batteries, loose in the drawer, nothing. Dang teenages, you would think they would throw bad batteries out!
Open new package, put those in, nothing.
Check all knobs, dials, buttons, nothing.
Crap, camera died.
Spend the next 4 days researching new cameras, and being really really perturbed that my favorite camera of all times is dead.
Need to take a couple snap shoots. Grab the Nikon 3200 and shoot them.
Humm, can't seem to get the SD card in the card reader (dark in the computer room, light is burned out and no replacment bulb in the house).
Grab flash light. What is this! Seems to be an XD card in the card reader.
Pull out XD card, replace in S5200, turns right on!


fofa is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:52 PM.