Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Mar 14, 2009, 8:55 PM   #1
Junior Member
Subnet76's Avatar
Join Date: Apr 2005
Posts: 20

I have a barely used S5100. But it was dropped and the battery cover wont stay shut because of the clips on the camera side are broke. Is this something that can be fixed? Or should it just be trashed?
Subnet76 is offline   Reply With Quote
Sponsored Links
Old Mar 15, 2009, 8:10 AM   #2
Senior Member
Join Date: Mar 2005
Posts: 1,870

Duct tape? At least as a temporary fix...

I think those clips on the camera side are part of the battery holder unit, and therefore should be replaceable. I don't know where you could purchase one, except from Fuji, and couldn't even venture a guess as to how much a repair might cost. I'd call them and ask before trashing. In the mean time...duct tape it.

the Hun

rinniethehun is offline   Reply With Quote
Old Mar 16, 2009, 4:48 PM   #3
Senior Member
dr_spock's Avatar
Join Date: Nov 2006
Posts: 879

You could try a hair elastic to keep it closed. Or tap in some small screw heads to take the place of the plastic clips on the body.

dr_spock is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:35 AM.