Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Oct 24, 2012, 6:59 AM   #1
Junior Member
Join Date: Oct 2012
Posts: 2
Default Finepix viewer help!

Apologies if there's already a thread on this!

I have a Fujifilm finepix S1600 camera. Around a year ago it worked fine on my laptop, I could upload my pictures to my laptop with no problems. I had problems with that laptop further down the line and ended up getting a new one, I haven't used my camera since I got this laptop (a fair while ago). I know I have to have the disc (or so I've been told) to view my pictures on finepix, which I don't have, so I tried to worm my way round it and downloaded finepix online - which I think is the correct one just updated.

It will NOT work for the life of me! It isn't coming up in the 'My Computer' area, nor is it coming up in finepix?!? I have two cables and I've tried both, I've tried both USB ports - you name it. I plug it in switched off like it says in the manual and hold down the green view button for a second so it switches on that way; still nothing!

Is there anything I can do or am I buggered for life? LOL. Sounds like a daft thing to say but I've tried, or what seems to be, everything I'm going to Doncaster wild-life park tomorrow and I could really do with it working!

Last edited by savanna; Oct 24, 2012 at 7:01 AM.
savanna is offline   Reply With Quote
Sponsored Links
Old Oct 24, 2012, 1:17 PM   #2
Join Date: Jan 2012
Location: Spain, Costa Blanca.
Posts: 90

If it's not showing on your computer then I don't think you have downloaded it correctly. Go to your downloads file and see if there is an .exe file there for the program. If there is open it and follow the instructions, if there's not then go back to the website and re download it. You ought to be able to transfer the files directly from your camera to the computer and then open them in which ever program you have.
If the camera doesn't showup on the computer then the problem is with the camera. If so try downloading the latest system onto your camera.
Sorry this is a bit disjointed but I keep thinking of things!! I hope you can solve the problem.
You know you're getting older when your mind makes commitments your body can't meet.

Fujifilm HS20-EXR & Pentax K20D
18-55 mm DA & 28-200 Sigma 3.5/5.6 ex SLR

My Flickr account
Mito is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:54 PM.