Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Apr 27, 2004, 11:57 AM   #1
Junior Member
Join Date: Apr 2004
Posts: 1
Default S2 Pro Battery Problem?!

dear all,

Having a slight issue with my new-ish S2 Pro. I've noticed at times when i've been taking shots, that suddenly the camera will give a long bleep, and the CR-123 battery indicator (On top of the camera) will flash showing a half battery, or half full, and the camera switches off. When switched back on again, it can sometimes appear Full again; you take a picture and the same thing happens, camera bleeps, indicator flashes, and camera switches off!

Does the camera not give a better warning of a rundown battery i.e. icon progressivly goes from full, then to half, and then when just about running out bleep and switch off. If so, mine's doesn't!!

I've taken out the batteries that it rejects to use again, and tested some of them, and my battery tester indicates that while some of them have definately run down, others that look like they have enough power, the camera rejects.

Anyone know anything about this?

astrobhoy is offline   Reply With Quote
Sponsored Links
Old Apr 28, 2004, 5:01 PM   #2
alan sh's Avatar
Join Date: Feb 2004
Posts: 76

Its been reported that the CR-123 doesn't last very long but I have no personal experience with an S2Pro (I'm open to offers) so I cannot comment on the indicators.

However, my F602z gives me no indication at all - it just stops when the batteries run down.

I guess the answer is to always have some spares with you.
alan sh is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:52 PM.