Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Jun 25, 2005, 11:25 AM   #1
Junior Member
Join Date: May 2005
Posts: 5

My S5100 has finally arrived after a long delay by Dell.

Is there a checklist of features to examine or testso I can discover any bugs or defects during the return period?

I am trying to work my way through the owner's manual. This is my first digital camera, and my first camera that is not a pure "point and shoot." At the recommendation of other readers on this forum, I have obtained from the library the book, "Understanding Exposure" by Bryan Peterson so that I can learn about the manual settings of my camera.

Is there anything else I should be reading or studying?

Thank you, Stu
stususs is offline   Reply With Quote
Sponsored Links
Old Jun 25, 2005, 11:43 AM   #2
Senior Member
Join Date: May 2005
Posts: 1,058

If this is your first digital camera, then I would suggest that you not worry about all of the manual features to begin with. If you do, I'm afraid you will quickly become frustrated. My suggestion would be to put the card in the camera and start taking pictures in the different automatic modes that are built into the camera. Find out what works for you and what you need to work on to improve. Don't worry about looking for things that are wrong with the camera. Whenever I start using a new camera I assume everything is fine to begin with.

When I first got my 5100, I seemed to have difficulty getting what I thought were good clear pictures. It's easy to start blaming the camera when in fact the problem was me. I immediately set the ISO to 64 rather than leaving it on auto, and I wasn't very pleased with the results of first pictures. The other camera that I had been using produced so much noise at higher ISO settings that I was determined not to use them on this camera. For me, this was a mistake.

Take a few pictures with everything set to automatic. Then try the different program modes that are built into the camera. Then started experimenting with other features. I think it's best for you to just get a feel for what the camera will do and how it responds.
jphess is offline   Reply With Quote
Old Jun 25, 2005, 9:08 PM   #3
Join Date: Feb 2004
Posts: 41

I agree with all that was stated previously. Forget looking for what is wrong with the camera and just use it. If there is a problem, it will show up in regular use.

I am a proud owner of the very same cam and I find it a great camera for the price. You will find out a good bit of its capabilities before the warranty runs out, unles you have a seven day warranty and will learn its weaknesess and flaws after a while.

So enjoy your camera and have fun!!

Just a pic to show what the cam is capable of, and I am sure in better hands, it will produce better pics!!


dudlew is offline   Reply With Quote
Old Jun 27, 2005, 10:18 PM   #4
Senior Member
Join Date: Jan 2005
Posts: 149

I aree with the previous posters, get used to using auto mode, you can learn manual, and other modes later,,, just go & take indoor, & outdoor, pics so you can get the feel of the camera,,,, (Also, an important note here: Whenever you leave "auto mode", you lose auto ISO,,, you must choose an ISO speed,,, AND, when you go back to "auto mode" you must reset the ISO speed, it will not go back to auto ISO by default!)

Aside from this, the camera does a great job of metering the ISO, Aperature (F-stop), and shutter speed, to deliver clear colorful pics, in any light, under mostall conditions.
MikDee is offline   Reply With Quote
Old Jul 8, 2005, 12:46 PM   #5
Junior Member
Join Date: Jul 2005
Posts: 1


I recently bought S5500 thru ebay india.This is my very first cam.Now the problem is the the lens casing (which comes out whem the cam is switched on) is not firmly fixed .if we tilt the cam a small shaking sound like something loose inside the cam is heard. Is it a serious defect ?Apparently no problem with taking pictures..Pls help. I am new to this.

Thanks and Regards

jis_rainbow is offline   Reply With Quote
Old Jul 8, 2005, 2:27 PM   #6
Senior Member
Join Date: May 2005
Posts: 1,058

There have been other threads regarding this issue in this same discussion forum. It seems that this is a common trait with this camera model. Apparently, from what I have read, it is not something to worry about. I have attached to the lens hood to my camera, and have not paid any attention to see if my camera behaves in a similar manner. I suppose if you want to worry about it you can, but I don't think it is necessary.

jphess is offline   Reply With Quote
Old Jul 8, 2005, 3:31 PM   #7
Senior Member
Join Date: Mar 2005
Posts: 1,870


Good luck with your new camera. I say, put it on AUTO and fire away...outside, inside, with and without flash...take some macros...take some tele's, long range, short range...take lots of pictures! Learn what your camera can do in all situations without manual adjustments. If anything is seriously wrong with your camera, it should be obvious. Once you fell comfortable with the cam, then start experimenting.

the Hun

rinniethehun is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:49 PM.