Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Fujifilm

Thread Tools Search this Thread
Old Nov 6, 2005, 2:27 PM   #1
Junior Member
Join Date: Nov 2005
Posts: 1

OurFuji S5000 has been making a loud "clicking" noise each time the flash is used for about the last two weeks. Now the flash only seems to work periodically. Should I try and get it fixed or just go out and get a new camera?
lenvo65 is offline   Reply With Quote
Sponsored Links
Old Nov 8, 2005, 8:17 PM   #2
Senior Member
shutterbuggy's Avatar
Join Date: Jul 2004
Posts: 188

Assuming the S5000 to be slower, consuming more energy, at only 3 MP - I suggest you'd be (much) better off getting the S5200!
shutterbuggy is offline   Reply With Quote
Old Nov 8, 2005, 8:34 PM   #3
Junior Member
Join Date: Nov 2005
Posts: 21

my 7000 just had it's flash tube blow... and i intend to get it repaired

I just got a 9500... intending to use whilst the 7000 is away, but it seems I got a bad one, so that will have to go for repair first

I use them in my studio so the 7000 is using an external flash unit right now to trigger my main light

my friend has a 5000 and loves it.... another one has the 5500 (4mp.?) and loves that... the new 5600 (5mp.?) seems to be good and without the teething troubles of the 9500

if you are out of warranty ... and I were you ...I'd probably go for the 5600... or if you don't mind a bigger body...the S20 which is low priced but has a better sensor than the 7000
fabianfred is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:47 PM.