Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jan 30, 2008, 12:07 PM   #1
Junior Member
Join Date: Jan 2008
Posts: 4

My trusty ol Canon S40 won't power up anymore. Nothing happens either in view mode or picture mode. Tried 3 different batteries - nothing.

Is this what happens when DCs die?
gerrygr1 is offline   Reply With Quote
Sponsored Links
Old Feb 1, 2008, 11:23 AM   #2
Senior Member
Join Date: Dec 2006
Location: Davenport, IA
Posts: 2,093

Short inside camera = die! If it didn't smoke it's an open not a short but for practical purposes it's still dead

If you've tried known good batteries and it still doesn't power up it's dead and unless it's under warranty replacement is in order. If it's under warranty it will still probably be replaced.

My observation is that the mechanicals wear out (zoom and focus motors, covers, etc.) more frequently than circuit failure (except switches) but circuitry can fail. It is possible that you have a failure in the power switch. Did you have any period of intermittent operation where you had to "play" with the on/off switch to get it to work?
ac.smith is offline   Reply With Quote
Old Feb 1, 2008, 7:04 PM   #3
Senior Member
BillDrew's Avatar
Join Date: Jun 2002
Location: Hay River Township, WI
Posts: 2,512

Have you tried cleaning the battery contacts in the camera? Not real likely to solve the problem, but worth looking at.
BillDrew is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:45 PM.