Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jan 4, 2014, 11:56 PM   #1
Junior Member
Join Date: Jan 2014
Posts: 1
Default Need please help Vivitar 400mm Telephoto 5.6

hi i have just bought Vivitar 400mm Auto Telephoto 5.6
this lense has tx mount but the lense came with TX to MD adapter
now i m trying to use this lense with my canon 7D eos (ef)
so now i can use MD to EOS(ef) adapter which is putting two adapter on the lenses.
i was thinking if i could get TX to M42 to EOS adpter which works out better for me because the M42 to EOS i have is very thin.

i also came across

Vivitar Automatic Tele Converter 2x-1 wich is m42 mount.this work out for me
the only thing is that the Tele Converter is M42 from from one side but not sure wich mount is it(TX T2 or T4)?

this is a link regarding the tele converter

Attached Images
lalu38 is offline   Reply With Quote
Sponsored Links
Old Feb 24, 2014, 7:21 PM   #2
Junior Member
Join Date: Feb 2014
Posts: 1

Hi Lalu38,

I also got a vivitar 400mm, but for my Sony NEX. The problem is that I don't know what adapter to get, because I don't know what mount it has (or is it missing a piece?).

Can someone help me figure out what mount is this? the piece on tope rotates about 45-60 degrees and it's hold by a little screw on the side.

Attached Images
littlesamurai is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:39 AM.