Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Apr 18, 2004, 9:25 PM   #1
Junior Member
Join Date: Apr 2004
Posts: 1
Default Shutter Lag ??

Which brand is best in this regard? I'm looking to upgrade to 3 or 4 megapixels and would love a 10x zoom. I'm looking at the Olympus C-740 and 750, but don't know how their lag time compares to other brands. Any better options out there in the same price range?
Redmist is offline   Reply With Quote
Sponsored Links
Old Apr 18, 2004, 9:40 PM   #2
Senior Member
Join Date: Feb 2004
Posts: 269

The Minolta Z1 and Z2 have really low shutter lag, so you could look at them. I like the speed of my Z1 a lot, but the momentary blacking out of the EVF makes it hard to do sequence shots of auto racing. When you have cars whizzing by at 100 mph, it takes quite a bit of guesswork trying to figure where the car will be when you can't see exactly where the camera is. But I imagine other cameras in this price range have the same problem.
murphyc is offline   Reply With Quote
Old Apr 18, 2004, 10:59 PM   #3
Junior Member
Join Date: Apr 2004
Posts: 21

The new Pentax S4i which I ordered and should arrive in a couple days has specs showing essentially no lag after depressing the shutter midway in order to preset the autofocus. www.pentaxusa.com
bakpakr is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:43 PM.