Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old May 3, 2004, 11:06 PM   #1
Junior Member
Join Date: May 2004
Posts: 1


Well, I just got my brand new Olympus C-5000 and I notice that there are two little "dots" visible in the LCD display (only visible when on). Fortunately, they do not show up in my photos but they really are annoying. It looks like it could be dust or perhaps just a couple of "dead" spots. They are not large but they certainly are noticeable. I'm looking for some opinions. Would you return it and have it replaced or is it not worth the hassle? Is this common? Thanks for any advice you may be able to offer.


4-Eyes is offline   Reply With Quote
Sponsored Links
Old May 4, 2004, 5:41 AM   #2
Nagasaki's Avatar
Join Date: Jan 2004
Posts: 897

I don't think it's common but it may be within operational parameters. If it's anoying you I'd try to get it changed but you may find that there's a minimum number of dead pixels required before it can be changed. The ISO standard for TFT computer monitors allows 2 dead pixels and up to 5 dead sub pixels. I have no idea what standard applies to the smaller screens.
Nagasaki is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:17 AM.