Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Aug 2, 2004, 6:14 PM   #1
Junior Member
Join Date: Jul 2004
Posts: 26

I did the A2 firmware update and everything seemed to go okay.
As instructed I turned off the camera when the 'update completed' message appeared.
When I tried to turn it back on it would not power up and I got the low-battery flashing icon.
I charged the battery and the camera still indicated 'low battery.
I went to the camera store and the battery tested as fuly charged.
What happened? How do I fix it?

smartyboy is offline   Reply With Quote
Sponsored Links
Old Aug 3, 2004, 12:50 AM   #2
Senior Member
Mikefellh's Avatar
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707

You better talk to Minolta about that one, or ask in the Minolta forum here...most likely the camera will have to go back to the factory to be fixed. If you have the camera connected via USB will it power up then?

Did you get the firmware file actually from Minolta, or was it on someone's personal website; my thinking is the firmware was hacked so it would ruin cameras.
Mikefellh is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:13 AM.