Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Aug 3, 2004, 1:42 AM   #1
Join Date: Jun 2004
Posts: 52

I have a Powershot A75. I just want to know whether slave Flash ( Digi-slave - DSC1 or similar) works with these cameras. I also do not know how to attach these flashes. Any information please ? Is it worth buying a slave flash for A75 ?
hari is offline   Reply With Quote
Sponsored Links
Old Aug 3, 2004, 4:24 PM   #2
Senior Member
Mikefellh's Avatar
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707

Never heard of that model Digislave, and it's not listed on their site:


Depends on what you photograph, slave flashes can be quite worth it...check out what the SRElectronics site shows.

I personally use a Metz digital slave flash, and I can light up the night with it:
That was taken in complete darkness with my Metz at full power (I don't have one with just my internal flash, but it would be a LOT darker as that was quite a few feet away as internal flashes are only good for about 15 feet).

Digislave brand works with cameras that have preflash or not, so it will work with any camera...if all else, to test see if the flash works properly with your camera, what you do is put it on the counter facing the camera and take a picture...if you see the flash firing in the picture, then the flash will work...if the flash is dark, then you might have to change a setting on the flash or it's not compatible...here's the test I did with mine in the store when I bought it to see if it works with my camera's preflash:
Mikefellh is offline   Reply With Quote
Old Aug 3, 2004, 4:38 PM   #3
Senior Member
KCan's Avatar
Join Date: Jul 2002
Posts: 1,625

hari wrote:
Is it worth buying a slave flash for A75 ?
hummmmmmm ... IMHO, the choice of a flash depends what you need as lighting more than what you own as camera. Anyway,a slave flash can be used with different cameras , more or less expensive.
KCan is offline   Reply With Quote
Old Aug 6, 2004, 8:54 AM   #4
Junior Member
luka_glo's Avatar
Join Date: Aug 2004
Posts: 13


I have averysimple slave flash which I used with my old 'analog' SLR. It worked very well - it was triggered by the first flash with no possibility to adjust to second... and this is where the problem with slave and digital cameras may lie. Most digicams use a pre-flash to fine focus and adjust exposure (I guess ...) then the main flash goes off and the photo is taken. Most simple slaves will go off at the first flash and will have no effect on the picture.

There are therefore two solutions: either buy a more expensive slave that can be adjusted to first or second flash or use an external flash on your camera. Such external flash guns usually do one flash. It means that most of your picture control has to be done manually !:sad:

Hope this helps - all the best !
luka_glo is offline   Reply With Quote
Old Aug 6, 2004, 9:10 AM   #5
Join Date: Jun 2004
Posts: 52

Thank you friends. It is great to have got doubts clarified with so many of you are coming forward to give solutions. Once again thanks for the information.
hari is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:21 PM.