Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Oct 15, 2004, 4:44 AM   #1
Junior Member
Join Date: Oct 2004
Posts: 2

:? Look at the attachment and tell me why does the picture look so rainbow like i know its not from the flash because everyone of my pics look like this now, is my camera broken how can i fix if i can
Attached Images
metaljeffk6 is offline   Reply With Quote
Sponsored Links
Old Oct 15, 2004, 9:09 AM   #2
Senior Member
Mikefellh's Avatar
Join Date: May 2004
Location: Toronto, ON, Canada
Posts: 1,707

YOU can't fix this problem, definately an issue for a repair outlet or buy a new one. Almost looks like the camera got wet (but can't say for sure). I doubt this would be covered by warranty (if it's still in warranty since you didn't say which side of a year it's been, assuming a 1 year warranty).

You could always send Kodak an email with the sample and ask them.

Digicams are more complicated than people think...as someone who used to fix home electronics digicams require advanced to master knowledge for repairing and to track down this problem would be very difficult for someone who isn't experienced in diagnosing digicam failures.

Although you only owned it a year, the model is over three years old now so you may want to decide to buy a new camera rather than putting the money into getting this one fixed.
Mikefellh is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:10 PM.