Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Nov 18, 2004, 12:30 AM   #1
Junior Member
Join Date: Nov 2004
Posts: 1

Hi, I have an Olympus D-520 Zoom digital camera (I know, it's an older model) and just recently I've been having a problem. Basically, it won't take pictures at all. I open it to expose the lense, put it on the pixel setting I want, and then wait for the orange blinking light to stop to tell me it's ready to take a picture. I press down half way to focus, and then all the way to shoot, but nothing happens. Then the orange and green light will both start flashing, and none of the buttons will work. Is it over? Is my camera dead? I've had it for about two and a half years...isn't that a short lifespan for a camera?

Any advice at all would be helpful. Thanks in advance!
Cuno is offline   Reply With Quote
Sponsored Links
Old Nov 20, 2004, 6:59 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

I would check for obvious problems first...

Batteries - make sure you havegood batteries in the camera. Weak batteries can cause problems (and they don't last forever). If you're still using the same rechargeable batteries from over 2 years ago, it's probably time for replacements, as they may not be taking a complete charge anymore. ;-)

Memory Card -- I'd make sure to format the card with the camera menus (not the PC), after making sure you've got good batteries in the camera. If you have another card, try it.

Switches and Buttons -- try all switches and buttons a few times. Sometimes you can get a little oxidation under one (or one that hasn't fully released causing a problem).

Reset Camera to Defaults -- just to make sure a setting isn't causing a problem, try resetting the camera back to factory defaults. Your camera has an "All Reset" menu choice under it's Setup menu that will reset the camera back to defaults upon power down. If this doesn't work, try leaving the batteries out for a day or two (this will often cause a camera to lose all settings, forcing it to "reboot" back to factory defaults.

If all else fails, you may also want to make sure the battery contacts in the camera are clean (sometimes a touch of oxidation can build up on them, limiting current flow from batteries). Radio Shack sells a pen style contact cleaner for this purpose with a contact cleaning liquid that flows to it's tip. Be careful as contacts are delicate.

Good Luck.
JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:36 PM.