Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Dec 2, 2004, 7:32 PM   #1
Junior Member
Join Date: Dec 2004
Posts: 1


i just got (yesterday) a new digital rebel. I got the package that came with the lens.

I've shot about 100 pics so far, and keep getting "error 99" over and over again, but it's not consistent. sometimes i can take the shot with no error, sometimes not.

i've done the battery and lens thing, to no avail.

should I return the camera to the store?
torontonic is offline   Reply With Quote
Sponsored Links
Old Dec 2, 2004, 7:58 PM   #2
Senior Member
Join Date: Dec 2003
Posts: 575

Error 99 is (stright from a tech rep for Canon) "Canon's generic error code for just about anything"

If you just purchased the camera, I would definitely exchange it. If you cannot, call Canon, get an RMA #, and send it to your closest repair facility.

There could be any number of things wrong inside the camera...

Gandalf065 is offline   Reply With Quote
Old Dec 2, 2004, 8:05 PM   #3
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,370

I've seen numerous techniques for trying to fix it -- for example: cleaning contacts on lens and camera body, removing batteries including the button battery, etc.).

But, it sounds like you've already tried some of this. So,I'd get it repaired or exchanged.

JimC is offline   Reply With Quote
Old Jun 4, 2005, 8:42 PM   #4
Junior Member
Join Date: Jun 2005
Posts: 1


I have had the same problem with my digital rebel, I tried everything!!! I finaly found what to do to fix it!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

after you fix yours please email me to let me know if this works for you!!!

MY email is LLewis1830@yahoo.com my phone # is 937-669-2324

I cant believe it has not been mentioned before!!!

there is a small Watch type battery located just inside the bp511 battery compartment on theside of the area as you look down into the open Empty battery area, i found it by accident!! It says CR2016 (the disc type watch type battery) simply slide it out twards you, you will find a round battery, after replacing it you will need to reset your date and time, this will come up when you turn you camera on! im sure i lostall of my setting but who cares i can reset them! my camera works like new!! please let me know if it works for you!!

thanks and good luck

llewis1830 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:36 AM.