Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jun 15, 2005, 9:10 PM   #1
Junior Member
Join Date: Nov 2002
Posts: 18

If you've had the occasion to contact your digicam's manufacturer for support ... how do you rate them? Did they resolve your problem and seem knowledgeable about the product or did it feel like standing in line at the DMV?

My two recent experiences with Konica-Minolta USA were so frustrating that I returned my Z20 to the dealer. K-M USA does not reply to email and the phone staff has remarkably little knowledge of the product. Any question necessitates an "escalation" to a "specialists who will call back but never does.

While my Z20 does not have a problem at the present time I am relucatant to own a product from a company who has shown me that they can not (or do not care to) support it.

We appreciate Steve reviewing the hardware but reviewing the camera companies would be REAL valuable inforamtion to have before forking over considerable money for a high dollar camera.
subeluvr is offline   Reply With Quote
Sponsored Links
Old Jun 16, 2005, 3:34 AM   #2
Senior Member
Stevekin's Avatar
Join Date: Jun 2004
Posts: 1,611

In contrast, I haveon a few occasions contacted KM UKwhen I have wanted information for myself and on behalf of other members. Each time the response was in a day or two, sometimes the same day. All my questions were answered satisfactorily and I have been pleased, maybe relieved, in all correspondence with them.

I have done this via email and the phone.

Now this could be that I was fortunate to get a KM employee who enjoyed his job and understood the actual meaning of customer support, it could be that each time was more a question and answer exercise and if I needed to ship the camera I may have encountered problems, I don't know.

Sorry you felt you had to return your Z20, obviously a problem with it,but could you not just exchange it with the supplier ? I'm sure you would have enjoyed that camera, I love my (now) antique A2.

Anyway, good luck in your next choice.

Stevekin is offline   Reply With Quote
Old Jun 16, 2005, 4:23 PM   #3
Senior Member
Join Date: Dec 2002
Posts: 5,803

I've had interestingly mixed result with Canon.

I broke my camera (20D) & lens (600mm f4! Ouch!) It was all my fault, I completely admit.

Note all items were out of warrenty.

I sent those two and two other items.
My 100-400 had slowly gotten worse over time. The zoom lock (clutch) stopped turning & the zoom stopped sliding. They claim I dropped it, I don't recall doing it, but as I said... it got worse over time. I could have forgotten.
My 1.4x Tele Converter had a problem with the locking/latch mechanism. It wouldn't spring lock, I had to push the lock in myself. But once done, it stayed locked. So why not get it fixed?

They shipped all but the 600mm back in a reasonable amount of time (fairly fast, actually) and didn't charge me an arm and a leg. All was good.

The 600mm, though, took almost twice as long as they said was the average. And when I got it back it wasn't fixed. The IS didn't work. I couldn't test that as broken before... and the box they shipped it in was clearly dented on the side. It was also one of the worst packing jobs I'd ever seen, $7,500 worth of equipment and they packed it with 4 large crumped pieces of paper around the box I carrying case. No bubble wrap, no peanuts. My guess is that it broke in shipping, but I don't actually know.

They dealt with this very well, actually. No hassle in getting it fixed, and they did it much quicker than before. And it worked great. They didn't tell me it was coming (either via (e)mail or phone) so it was only luck that I was home to receive it. That was annoying, but not serious.

The first big trip after that I noticed that the lock was failing on the 1.4TC. Unfortunately it was worse. It came unlocked once in my hand. I should have just stopped using it there, but I was used to the lock being tricky. After about 10 hours of shooting, while carrying the camera over my shoulder (on a tripod) the TC lock failed and dropped my camera, flash & TC on to the pavement. It didn't turn on. This was over the last long weekend, so I had to wait until Tuesday morning to call them. Needless to say, I wasn't happy.

The kicker was that in 4 days I was going to a once-a-year nature photo trip. If I didn't have my camera their mistake would cost me shots (and potentially money.)

Well, they were fairly good about it. When I explained the problem to the 1st tier support, they offered (and it's what I wanted) to send me to their manager. They did, and he listened well and offered to send me to a customer specialist. He transfered me there (after telling them my story) and she explained that they couldn't get me a rental or replace the equipment (I wanted a new TC!) but if I shipped it right away and sent it to a specific manager's attention at the repair center they would do their best to get it to me by Friday.

And shockingly, they were able to do it. I was stunned. I send it Tuesday morning, they got it Wed morning, and they must have finished the repair (of the camera, TC, and a check over of the flash which was fine) by Thursday so I could get it by 3pm on Friday. I was stunned, quite frankly. (Note, I only paid for shipping to them. They offered to pay it, but it would have delayed it a day while I waited for the prepaid shipping label.)

The downsides are:
The battery (which had hadn't noticed was dented) was still dented. They didn't replace it, although I'm sure they saw it. Of course, it seems to work and doesn't leak. So maybe they didn't have to, per say, but batteries have ugly chemicals inside... I'd hate to have it leak.

It turns out the lens hood on the 600mm is actually cracked. They had two chances to replace it (and I bet they saw it) but they didn't.

And the final problem.... the TC isn't actually fixed!!!! It is back the way it was before I sent it to them. The lock doesn't always engage, but seems to stay engaged once locked. I haven't decided if I'm going to send it back or not... I really don't think I dare (unless they said they'd just replace it.)

So that is my story. It was really bad, but at the same time surprisingly good in other ways. And unlike your problem, I've had no problem contact them or talking with them.

eric s is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:47 AM.