Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Aug 29, 2005, 8:44 AM   #1
Junior Member
Join Date: Aug 2005
Posts: 4

just got this camera 7days old the lens nikon D50 kit

my problem is this

help me, is this just dirt on the ccd?(i opened and placed shuter on bulb mode and looked at the ccd i saw nothing there with my eyes). picture with no lens also had the spot

i have looked at all my pictures, i can see this dot in every single one, some more obvious some less.

should i return it to the store, ask them to clean it? return it and replace?(could it be a defect not just dirt?) or go somewhere else to clean it?

i bought it at bestbuy here in canada no extanded service plan!

thx for any assistance!!
devils-haven is offline   Reply With Quote
Sponsored Links
Old Aug 29, 2005, 9:43 AM   #2
Senior Member
Join Date: Oct 2002
Posts: 544

You have some dust on the sensor. Use the procedures outlined in your manual to blow the dust off the sensor... suggest you start with a blower. Do NOT use compressed air.
Wildman is offline   Reply With Quote
Old Aug 29, 2005, 10:40 AM   #3
Junior Member
Join Date: Aug 2005
Posts: 4

ok thx, just tried it, think i got it off ( had a blower from when i bought my vid cam took off the brush and just blowed on it)

tried few test shots think i took it off, but i am suprized blowing with somthing liek this( small and berly blows anything) would work i will see

in any case could u tell me how much would it cost me to get it profesionaly cleaned? when the time comes?

thx for the help didn't even know i had a blower till i googled to what it is lol
devils-haven is offline   Reply With Quote
Old Aug 29, 2005, 4:54 PM   #4
steve's Avatar
Join Date: Jun 2002
Posts: 2,535

Best way to check for dust on the sensor is to set it on Aperture priority modeandusef22 or whatever the smallest aperture is for your lens. Use manual focus, point at either an open area of blue sky or a solid white wall and take a picture with the lens purposely out of focus. Any sensor dust will be easy to find when you examine your image at 100%. Oh yes, be sure to use lowest ISO speed (i.e. 200).
steve is offline   Reply With Quote
Old Aug 29, 2005, 7:25 PM   #5
Senior Member
Join Date: Jan 2004
Posts: 2,483

In general it's important to learn how to clean your sensor. There are numerous links all over the place on how to do this.

It is VERY important to do this right. It's easy to damage the sensor when done wrong, but easy to do right if you learn how.

I've noticed that after a while, people tend to develop thier own individual techniques - but they all include the same safty precautions...

DBB is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:27 AM.