Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Oct 25, 2005, 11:09 AM   #1
Junior Member
Join Date: Oct 2005
Posts: 1

I have the Cybershot DSC-P93 camera and am a little disconcerted that it doesn't have a dummy setting for fast moving objects. Something like children running on a socker field will cause blurry pics. I tried setting the shutter faster but wound up with dark pictures.

Am I missing something easy here? This should be a standard feature, right? Does it have a shutter priority setting or something?

I was thinking about replacing this camera with the Canon A520 but if I can figure out this stuff I may not need to. The drawback with the canon is its poor movie mode and long flash recharge times.

iviguy is offline   Reply With Quote
Sponsored Links
Old Oct 25, 2005, 5:21 PM   #2
Senior Member
KCan's Avatar
Join Date: Jul 2002
Posts: 1,625

something can help:

1) use high ISO (set at 400, your max)
2) use manual exposure, and open aperture to max , you can have 2.8 at wide angle zoom
3) avoid too much zooming, aperture opening is max at wide angle, so you can afford higher speed.
4) try to "follow" the subject with your camera, the background can be blur, but less on your subject.

KCan is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:22 AM.