Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Mar 9, 2006, 11:09 AM   #1
Junior Member
Join Date: Feb 2006
Posts: 4

I've had a sony cybershot point and shoot digi cam for a little under a year now and it's already starting to break (The mode dial, to be specific) This is my first digicam I've ever had (and only one) and i was just wondering if most cams start to break after a year or so. I don't use it to much, just on vacations (2) and a couple other special occasions, but not frequently, which is why this issue upsets me so.
Also, would you reccomend buying from sony again?

Any Help is greatly appreciated

P.S.- If it should have a greater life expectancy, does anyone know if this would be covered in the warranty (the model is: Sony cybershot dscW1)
keybowvio is offline   Reply With Quote
Sponsored Links
Old Mar 9, 2006, 1:13 PM   #2
Senior Member
rey's Avatar
Join Date: Oct 2005
Posts: 949

Most cameras usually have a one year warranty, so check yours and contact them before it expires.

After I bought my P&S four years ago, a 2MP Fuji, I read that people had problems with it. The camera's lens goes in and out when you turn it off/on. People had complained about it getting stuck and they can't use the camera anymore. I've had mine for four years and it still works fine. I also used it a lot and got a lot of mileage out of it (10K+ shots so far). So in the end it's a crap shoot.

As far as buying from Sony, in general I trust Japanese camera companies, but I prefer "real" camera companies (Canon, Nikon, Fuji, etc) over electronics companies.

Check out Steve's Digicam list if you shop for one, but hopefully you can get yours fixed under warranty:

rey is offline   Reply With Quote
Old Mar 9, 2006, 3:32 PM   #3
Senior Member
vwmom's Avatar
Join Date: Dec 2005
Posts: 589

I'd take it to Sony... I had my p71 for just over 3 years.. and it was going strong when I sold it.. Though a little slower than when it was new. You should get 3-4 years out of any camera when taken care of, before noticing damage and/ or age.
vwmom is offline   Reply With Quote
Old Mar 12, 2006, 9:42 AM   #4
Senior Member
Carskick's Avatar
Join Date: May 2005
Posts: 276

We have a 3-4 year Fuji 2650 that still works like it did when it was new. It is very slow, and the coloring is not fantastic on it, but for an econmical digital of the time, it worked fine, and still does today.
Carskick is offline   Reply With Quote
Old Mar 12, 2006, 1:59 PM   #5
Senior Member
Reanimator's Avatar
Join Date: Nov 2005
Location: Huddersfield
Posts: 1,347

i have my trusty old olympus c4040 thats been at my side for a good few years, and its in fine shape, its had knocks and bangs and hasnt been treated with kid gloves.

gotta olympus e300 now as well whats treated with a bit more respect !!

they are pretty robust things and as long as u dont drop them or emerse them in water they should work for years, dirt, water , dust etc can cause probs with dials

have your vacations been near sand and wind (the beach)?? as thats not good for any camera

Reanimator is offline   Reply With Quote
Old Mar 16, 2006, 12:08 PM   #6
Join Date: Mar 2006
Posts: 38

If the electronics is going to go bad, the defect will usually show up within a month or so. Barring accident or abuse, long-term failures are usually the result of accumulated dirt or worn out contacts, switches, sticking mechanical parts, that sort of thing.

Digital cameras are no different. Aside from a few extra hot or stuck pixels on your imager, you can expect the electronics of your camera to perform much as it did when you got it throughout its useful life. A lot more of these things become obsolete than break or wear out.

My advice also would be to send the camera in for warranty repair; the switch should last longer than one year.
scoundrel1728 is offline   Reply With Quote
Old Mar 19, 2006, 11:37 AM   #7
Senior Member
sw2cam's Avatar
Join Date: Jun 2005
Posts: 358

August of 2001 my wife bought me a KODAK DX3215 digital. I thought darn that works kinda good for such a toy camera. When my Son shipped off to IRAQ I sent it with him as I upgraded to DX7590. That little rig worked the entire time he was oveseas. Time to come home he packed the rig in his seabag and came on home. After unpacking he found that it no longer worked. I was thinking about sending it to KODAK for trade in but thought why?, I don't need another cam. So I opened the thing up. I blew out the dust and grit. I took contact cleaner to all connetions I could get to. I put it back together and dropped in a fresh battery. The fool thing fired right up and still works today..
sw2cam is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:41 PM.