Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old May 13, 2006, 7:26 AM   #1
Senior Member
Join Date: May 2005
Posts: 493

I just got a 60GB hyperdrive (Portable storage device) and it's LCD screen (not color, just a display of a file browser, sucessful transfer, and battery life) has 2 small stock pixels in close proximity to each other when I turn on the device. They stay there thru it's opperation.

Now, I"m a little anal when it comes to things I buy having defects, dents, scratches, probelms and such. So I was wondering if this is a big deal or should I really not worry about it. I don't think it will affect the opperation of the unit or it's usefulness. Is it really worth it to try to get it repaired or replaced (Sanho states I have to pay for shipping to get it to them and they will match on the return back to me). It is the only thing with the device I can notice is worng.

Do stuck pixels get worse over time? i don't knw the resolution of the display but it isn't high. And it doesn't display pictures just text and symbols. Kind of like the LCD on the top of a dslr that display the number of pictures left and settings.

So what is everyone elses take on this? For me I'd like to have a product that is perfect without any issues. THen again most things aren't perfect and have minor blemishes. And the only "blemish" i can see with this product are 2 small stuck pixels.
nelmr is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:10 AM.