Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jul 10, 2006, 8:28 PM   #1
Junior Member
Join Date: Jul 2006
Posts: 11

Hello all. I recently replaced my beloved SD400 (E18 error) with an SD600. After one weekend of shooting, the quality of the pictures doesn't seem up to par with my SD400 shots. When you view the pictures at 100%, there is a great deal of noise. Is this from the new smaller CCD's Canon is using? All I want is great pictures on AUTO settings. Is my camera just a dud?

I was looking forward to the larger LCD (with high resolution), but it actually doesn't seem like much of an improvement. And when you zoom in to check if your pictures are sharp and clear, they instead look blurry on the screen so I cannot tell whether I took a nice pic or not. Once they are transferred to the computer, though, they look fine. Additionally, that stupid hand shake warning comes up on nearly ever picture with my SD600, a problem I didn't have with the SD400.

I want to get my camera from Costco because of their great return policy if something goes wrong. I'm considering returning the SD600 for the SD550. The CCD is better on the 550 I believe, although I'm nervous about the low resolution 2.5" LCD. The gold is ugly, too, but ultimately I just want great pictures without having to carry around my A95 everywhere.

Thoughts? Thanks!
snowairg is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 2:22 AM.