Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jul 18, 2006, 8:13 PM   #1
Junior Member
Join Date: Jul 2006
Posts: 5

Well, I have had problems with corrupted images on 2 different 3 year old Kingston CF cards. I don't mind buying a new CF card but could this be the camera (Canon S50)? On the first occasion, I lost a whole shoot when I got a bad media message. On the second and third occasions, I switched form a 1GB card to a 512. Well, the next time, I shot about 20 images flawlessly and then it corrupted a previous image. It literally collaged part of a new image onto an old previously unflawed image.
I formatted the card and tried again. Shot about 20 the 30 images without error. I then shot again, went back to review some of the old images and got about a 20% corrupted image rate. I am going on vacation soon and want to try to sort this out beforehand. I don't mind investing in new media if this is likely to solve the problem but is there any realistic possibility the S50 could be the culprit?
phillydog is offline   Reply With Quote
Sponsored Links
Old Jul 19, 2006, 11:10 AM   #2
Senior Member
Join Date: Dec 2002
Posts: 5,803

I am no expert with the S50, so I can only talk about "Theory" not "Practice" or "Experience".

Yes, it is possible that it is the camera.
I feel it is unlikely because the types of corruption problems I've heard about are across the entire model line with a specific model card (for example, it would be every S50 with a Lexar 133x card. I'm not saying that is a problem, that is just an example.) I would suggest asking in the Canon section (not the DSLR area, the one for their point-and-shoots) and see if anyone else is having trouble.

eric s is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:25 PM.