Go Back   Steve's Digicams Forums > Digicam Help > General Discussion

Thread Tools Search this Thread
Old Jul 19, 2006, 4:54 PM   #1
Junior Member
Join Date: Jul 2006
Posts: 15


Last edited by K J; Apr 29, 2010 at 11:22 AM.
K J is offline   Reply With Quote
Sponsored Links
Old Jul 19, 2006, 10:08 PM   #2
Senior Member
pagerboy's Avatar
Join Date: Feb 2005
Location: Canada
Posts: 483

Where is this red spot on the photo? Camera under warranty?
pagerboy is offline   Reply With Quote
Old Jul 21, 2006, 11:31 AM   #3
Senior Member
E.T's Avatar
Join Date: Jul 2003
Posts: 921

Dead pixels are black, this one is bright meaning it's hot/stuck pixel.

Hot pixels are also more easily visible in long exposures, that's why most cameras take second dark frame exposure with long shutter times.
E.T is offline   Reply With Quote
Old Jul 21, 2006, 12:43 PM   #4
Senior Member
Join Date: Oct 2003
Location: Indian Rocks Beach, FL
Posts: 4,036

If it is still under warranty call Canon support. Companies have varying criteria for hot or stuck pixels. Some will fix one and others require more than one.

It isn't that abnormal to get a hot, stuck or dead pixel. The camera isn't unusable except maybe to you if it is bothering you that much. It is pretty easy to clone it out if it is particularly bothersome on a photo.

slipe is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:25 AM.