Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > H-P

Thread Tools Search this Thread
Old Jun 25, 2003, 10:31 PM   #1
Junior Member
Join Date: Jun 2003
Posts: 2
Default HP 720 broke in 48 hours :)

I got my HP 720 week ago and after 48h broke completly...not accepting SD card asking all the time to format it...when seting it without flash and iso100 the pic was turning to blue!!! and the HP logo got corrupted...hehe
Nothing against HP but i saw others having the same probs.I know that HP is gonna replace it else ill take a gun and @#$R%@## them
I live in Czech Republic (actually i study in CZ...im GreeK) and to get the TV-AV cable for the cam i had to order it from germany!!!!
I was searching for some mini-stereo-jack...nowhere!!!!! whats wrong with this type of connector??!!!??!!


the HP720 i bought is a fine camera with simple menus, normal features, good pictures, its the best for the money.
BUT!!! no TV cable, the Dock costs extra EUROs i think 50~70EUs and the sarter kit with recharger+4 Nimh(1800)+Case costs 50EUs HaHaHa!!! im not gonna make them rich You can buy ur own rechargable+case+recharger for lessssssssss $$ EUs etc...
as for the TVcable..buy the components and make it

_BLaDe_ is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:34 AM.