Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Thread Tools Search this Thread
Old Jul 26, 2007, 8:28 AM   #1
Senior Member
adric22's Avatar
Join Date: May 2007
Posts: 359

I've been doing video editing, conversions,etc.. for years. I'm as close as there comes to being an expert on .AVI and MPEG1/2 formats. However, I've never worked with .ASF files before. One of the first irritating problems I've had is that many of my friends and family's computers won't play them correctly. They play jerky, often pausing for as long as a second or two, then a few frames play, then the pause. At first you might think it is because the PC isn't fast enough. Some of these computers in question are 3 Ghz dual-core machines. Yet, I have an 800 Mhz machine at home that plays them just fine. So it definatly isn't a speed issue. Anyway, it irritates me greatly because I can't just put these videos on a USB drive, plug it in to a friend's PC and show them. I've even tried installing the CODEC that came with the Aiptek camera on their PC and it didn't help. I've tried upgrading/downgrading versions of media player, direct-X, Xvid codec, etc. So far I still haven't found the answer.

So... I decided to try something else. What about converting the streams directly to an .AVI? I don't want to re-compress them because I like keeping my files in their original form. Recompression would degrade the quality, and lets face it, with the Aiptek videos I don't want to degrade them anymore than they already are comming directly from the camera.

I found an old version of Virtualdub that still has .ASF support, and I also discovered another program I had called "SUPER" will also do stream conversion from .ASF to .AVI without recompression. I tried this and it seemed to work. The .AVI files played perfectly on my PC. I checked them all, and did frame-by-frame comparisons. After a while, I was confident the conversions were 100% successfull. And SUPER even has very simple to use batch-conversions. So I can just dump dozens of videos into it and tell it to convert them all to .AVI. Only one problem - On those people's PCs that couldn't play the original .ASF correctly, well, they can't play the .AVI at ALL!!!! It tells them it doesn't have a codec for it. I tried installing Xvid but that didn't seem to help.

So I'm still looking for an answer to either problem. 1) Why the .ASF won't play correctly on some people's PCs. and 2) what codec does Windows Media Player need installed in order to play the .AVI. Obviously, I don't have either problem on any of my PCs at home or at work. but I know of at least 4 PCs within my family that do have this problem, so it can't be that uncommon.
adric22 is offline   Reply With Quote
Sponsored Links
Old Jul 26, 2007, 1:03 PM   #2
fishycomics's Avatar
Join Date: Jul 2005
Location: NYC NY
Posts: 9,617

ah excellent point


1what o.s are they running?? would that make a difference? both my xp 98, and 200 and nt all work fine? win 7 will give you close info? win 8 hm never even seen that one. win 9 or higher works for me i stick with win 10?

Super-C withe the latest h264 works fine but lags at the end all white?

wish I had an answer sorry
fishycomics is offline   Reply With Quote
Old Jul 26, 2007, 11:42 PM   #3
Join Date: Jul 2005
Posts: 887


I hesitate to post this because you know what you're doing, but have you installed the DivX codec? You didn't mention it, and I think the Aiptek .asf and .avi files depend on it. Installing it won't uninstall XviD, but beware that if you install XviD after DivX, it will remove DivX and you'll have to reinstall it. To determine which codecs are installed on a pc:

/Start/Settings/Control Panel/System/Properties/Device Manager/Sound, video and game controllers/Video Codecs/Properties
sgspirit is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:53 AM.