Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Hybrid Still/Movie/MP3 Digicams

Thread Tools Search this Thread
Old Jun 18, 2008, 8:29 AM   #1
Junior Member
Join Date: Jun 2008
Posts: 1

I just got an ahd 720p and I have some questions. My camcorder doesn't turn off. The blue light is constantly flashing. Is it turned off or not? The camcorder doesn't respond to the power button. When I close the screen the blue lights keeps on flashing. Second question is can I update the firmware of a German AHD200 to 2.002? Maybe that will fix the power problem.

Edit: Just ran out of battery juice. Charging isn't working. RAWR! this is makin me mad
diamondback is offline   Reply With Quote
Sponsored Links
Old Jun 18, 2008, 4:38 PM   #2
Junior Member
Join Date: Apr 2006
Posts: 22

the same thing happened to me, if i removed the memory card, it would stop flashing and work normal but then it would happen again, i had to send the camera back to aiptek for warranty work. i suggest calling aiptek tech support
VitaminC is offline   Reply With Quote
Old Jun 19, 2008, 2:19 AM   #3
Senior Member
Join Date: Mar 2008
Location: Helsinki, FINLAND
Posts: 157

You have defective unit for sure, return it back to store, they should replace it.
Quenaelin is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:02 AM.