Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kodak

Thread Tools Search this Thread
Old Jun 11, 2014, 8:17 AM   #1
Junior Member
Join Date: Jun 2014
Posts: 1
Default I can't transfer pictures from my Kodak camera onto my computer! Help!?

I have a Kodak camera, and up until recently, I've been using my USB cable and Kodak EasyShare to transfer pictures to my computer. All of the sudden...well, something's wrong, and I just don't know what. When I plug in my camera to my computer using the USB cord, nothing happens when I turn the camera on---the EasyShare menu doesn't pop up like it used to. My pictures won't start loading, either. I get this message time and time again saying something like "Cannot get the device information."
I just don't know what's wrong...
I've tried everything I can think of---including attempting to download updated software from the "Kodak site," but all of those attempts failed; it kept saying I needed to "right click on the Kodak logo and select 'Shut Down'"...well, I tried every possible Kodak logo on my computer, and I was never given the option to "Shut Down."

Please, I need help! This is so frustrating...I have very important pictures I need to get on my computer ASAP!
Even if I don't use the EasyShare program, I need to get them on somehow!
Update : Thanks for all of your help ^.^"
I tried each of yours methods (as best I could) but, this stuff goes so totally over my head, I didn't really achieve anything. It's nearly 5 in the morning, and I haven't gone to bed...so I'm going to sleep on it ^.^"
Thanks again, guys

MichelleWThompson is offline   Reply With Quote
Sponsored Links
Old Jun 12, 2014, 2:45 AM   #2
Join Date: Sep 2013
Location: Newark, New York
Posts: 82

Have you tried plugging the sd card from the camera into the computer? Try uninstalling and re-installing the software.
Weebee is offline   Reply With Quote
Old Jun 12, 2014, 6:58 AM   #3
Senior Member
Old Boat Guy's Avatar
Join Date: Apr 2010
Location: East Texas
Posts: 360

When you plug in your USB cable does the computer give any indication of see you have done so? Try a different USB cable and different port if possible.

Plug the camera into your computer then check under My Computer to see if the device is being recognized. Regardless of the status of EasyShare your computer should still see the camera. Hope this helps
Old Boat Guy is offline   Reply With Quote
Old Jun 12, 2014, 7:30 AM   #4
Senior Member
gjtoth's Avatar
Join Date: Nov 2007
Location: Louisville, KY, USA
Posts: 6,715

Before you do any of the above, reboot your computer and try it again.
Gary ---- "The best camera is the one you have with you."
Pentax K-3 ~ Panasonic FZ1000 ~ Panasonic ZS40
My Gallery

Hebrews 13:3
gjtoth is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:29 AM.