Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Konica Minolta

Thread Tools Search this Thread
Old Dec 3, 2009, 1:30 PM   #1
Junior Member
Join Date: Jan 2009
Posts: 25
Default Dropped Z3, red hand

My Z3 was dropped, inside a case that was inside a bookbag. It fell about 30' onto a hardwood floor. I powered it up to inspect the damage. Booting up the screen image jumps up and down about 5 times (with an audible click each time), afterwhich it stabalizes and appears to function normally, with the exception of the antishake hand no longer being green but is instead red in color. I took approx 20-30 pictures after the fall, and as far as I can tell, the pictures seem as good as those before. I read elsewhere online the red hand indicates overheating.

Can I safely use the camera as is?
Can it likely be repaired (who would I contact)?

And lastly, as much as I'd hate to, what would be a suitable replacement? I use the 12x analog zoom, macro and super macro modes. I also like the manual, A, and P settings. I thought about looking at Sony, but would prefer the normal flash card.
HDon is offline   Reply With Quote
Sponsored Links
Old Dec 3, 2009, 1:48 PM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,367

It sounds like a failure of the Anti-shake mechanism. As for continuing to use it, I probably would (although it may stop working altogether at any time).

Frankly, I think you'd end up spending more than it's worth trying to get it repaired (and they may not have the parts to repair it anymore). I can remember seeing quotes of around $165 several years ago to repair that model.

Sony took over responsibility for Konica Minolta digital camera repair after they bought Konica Minolta's camera related assets. See this post for details:


But, I'd probably use it until it quits working and/or buy a new camera versus trying to repair it. If you decide to get a new camera, I'd start a thread in the What Camera Should I Buy? forum to get input from members about models they've found work well.
JimC is offline   Reply With Quote
Old Apr 11, 2010, 9:29 AM   #3
Junior Member
Join Date: Apr 2010
Posts: 1
Default Focused WOTS helped me

Hello HDon,
I fixed my Z3 by a Whack On The Side (WOTS) on the direction button area. This is how it works:
Power down your Z3 and attach the lens cap. Firmly grasp the grip of your Z3 in your right hand, with fingertips supporting the body between the lens and the grip. Whack the direction button area on the heel of your left hand. Turn on your Z3, and stabilization should be working again.
Mine turned on, but no controls worked, not even the off button! I removed the batteries, reinserted the batteries and turned on my Z3. The lens retracted, immediately extended, and then all controls were fine.
I can't believe your Z3 survived a 30-foot fall! I dropped mine only 1 metre, and it was in its case. The result was a shaky image on startup, the red hand, a myopic (could not focus greater than 1.5 m) autofocus, and an annoying concave shadow on the right side of the image. From what I have read on this forum, the WOTS may reseat a loose connection between the control panel and a second PCB.
I bought my Z3 because it had a viewfinder, was light, had a big, ultrazoom lens, and had an excellent supermacro mode. The things I don't like about the Z3 are the lack of autofocus in low light conditions, and chromatic aberration (purple fringes) at highest zoom.

Edwin Groot
DimageZ3 is offline   Reply With Quote
Old Apr 11, 2010, 9:47 AM   #4
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,367

I wouldn't suggest trying that if the camera is working with the exception of anti-shake, as you may cause it to stop working entirely.

The "whack..." fix is sometimes used to try and correct jammed gears in the lens mechanism (a common problem with this model), versus an anti-shake mechanism failure.
JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 4:28 AM.