Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Konica Minolta

Thread Tools Search this Thread
Old May 28, 2011, 9:58 AM   #1
Junior Member
Join Date: May 2011
Posts: 1
Default Dimage 7 screen issues, please help!

Hi, hopefully this is the right section to post in.
My wife's Dimage 7 has a staticy screen when turned on, which also shows up on photos (lines and bars). We have to turn it off and on several times to get it to work, and lately not even this has helped. I did a software upload, and the problem persisted.
I have changed batteries and continue to have the same problem, both for rechargeables and for regular alkaline.

We're Self-supported missionaries, so every penny counts. Is the camera done, or is there something simple I can do to try and repair it?
Lixothetinman is offline   Reply With Quote
Sponsored Links
Old Jun 4, 2011, 10:39 PM   #2
Junior Member
Join Date: Jun 2006
Posts: 5

Might be the FFB or first frame black issue. It was a problem with the Minolta sensors and I had it fixed on an A1 and my D7 for free by Sony. I am not sure if they are still doing it, but it might be worth an email to them to see if they are still fixing it for free.
Harleysheena is offline   Reply With Quote
Old Feb 27, 2013, 5:19 PM   #3
Junior Member
Join Date: Feb 2013
Location: Coventry, England
Posts: 2

I had the same problem with my DiMage 7i, its a known fault, I bought mine off a friend who told me there is a place that does a fix for this problem, I think he said it was free or cheap, he had this same problem before he sold it to me, he had sent it to them and he got it back and was fine, but unfortunately it has developed the same fault again as you have described, I will try and find out where he sent it . . .

Last edited by Mr Dee; Feb 27, 2013 at 5:21 PM.
Mr Dee is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 7:10 PM.