Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Konica Minolta

Thread Tools Search this Thread
Old Oct 6, 2004, 7:48 PM   #1
Junior Member
Join Date: Oct 2004
Posts: 1

Sorry to report that I had major problems with my Z3.

From the start uploading pics to the computer via the USB cable was painful, locking up and needing a reboot every few images. Minolta rep was advised and promised to investigate and advise. Was planning to get a reader anyway, so maybe not a dealbreaker.

Big trouble came after 7 days of use, blank dimly lit screen on bootup...only displaying an image after cycling through the viewfinder select switch. Zoom disabled. Camera broken!:?

Back to the dealer were I am relieved to say I got a complete refund. The camera was great while it lasted! Got about 100 good shots out of it. Will NEVER consider another Minolta digicam after this experience and can't recommend the Z3 to anyone. Careful out there!
Stuporzoom is offline   Reply With Quote
Sponsored Links
Old Oct 6, 2004, 9:26 PM   #2
Join Date: Sep 2004
Posts: 84

I had a problem with uploading on a friend's computer. It turned out to be a problem with the USB hub he had. When directly connected to the computer, transfers were fine.

I don't doubt other cameras have had failures as well.
KueH is offline   Reply With Quote
Old Oct 7, 2004, 1:41 AM   #3
Junior Member
neomagic's Avatar
Join Date: Aug 2004
Posts: 7

So you're not ever going to buy Minolta again in your whole life, because you got one bad unit, right? And you want to warn the whole world so they won't make the same mistake?

My Z3 was bad, too. I checked on the web, no one else seemed to have this particular problem. I returned it, got a new one and am happy with it. Now I'm enjoying a powerful camera at a bargain price.

Maybe you should try to get things in perspective...
neomagic is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:15 PM.