Go Back   Steve's Digicams Forums > Digital Cameras (Point and Shoot) > Kyocera / Yashica

Thread Tools Search this Thread
Old Jul 28, 2005, 3:14 PM   #1
Junior Member
Join Date: Jul 2005
Posts: 1

My finecam S5 broke on holiday when saving the 270th photo to a new 512md SD card. It switched off leaving the lens out and flash up. when I turn it back on, the kyocera screen appears in the lcd for about 10 seconds and then it switches off. Is there a fix for this? I don't mind taking a chance as I don't think it is worth a dealer repair as it would be better to put the money towards a new camera?? views please. However I like the camera as it fits in the pocket and takes good "snaps" & enjoy repairing things.
Thanks for any help/advice.

Bryen is offline   Reply With Quote
Sponsored Links
Old Jul 28, 2005, 5:02 PM   #2
Senior Member
Kyocera Kid's Avatar
Join Date: Sep 2004
Posts: 694

Today's cameras, digital, or otherwise, are generally quite complicated electronically and even electro-mechanically. Theskills and knowledge needed to pull an old Zenith E (or similar) apart, even quite competently, are quite different tothose needed to repair your S5. Frequently, it is more cost-effective to swap out a module than to try to repair it. Flexible micro circuit tracks and surface mount components make home repairs exceedingly difficult .... even for those used to handling such small components.

I wish you well with your experimentation!

Cheers, KK
Kyocera Kid is offline   Reply With Quote
Old Mar 7, 2008, 8:44 AM   #3
Junior Member
Join Date: Jan 2006
Posts: 6

Any luck. My camera also concked off.
JoydeepB is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 3:36 AM.