Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Sep 4, 2006, 11:25 PM   #1
Junior Member
Join Date: Sep 2006
Posts: 1

Hi everyone,
I just recovered some photos on my Smart Media card and pretty happy about it so I'd like to share it here.

The original thread that I followed advice from is here:

but it is not operational anymore and new posts cannot be added so I'm doing it here for the rest of the community... especially those in angst.

Win98 Acer Notebook
Transend 5 in 1 card reader through USB
64MB SmartMedia card (made in Korea with no brand) since Nov 2002
Norton Disk Doctor
Olympus C40 aka D40 in other regions since Jan 2002

What Happened:
On day 1, I started shooting pictures with my cam and by the 3 shot, the cam hung on me with some flashing number on the top LCD screen - I can't remember. I pulled out the card and swapped it with another 32MB card and continued to shoot without problems. I returned to the notebook to see if I could see any pics on the 64MB card but there was none. Interestingly, the free space showed that space was taken up. This is using Windows Explorer - properties. I didn't bother recovering the pics as there were only 3 of them and not too exciting either. I popped it back into the cam and formatted it. It worked after that. Tested a few shots without problems and deleted them after that.

On day 2, I used the camera again. On the 8th shot, the cam hung again! I was shooting rather furiously before that. I had done this sort of thing previously so I didn't think I did anything wrong. Well, the 'error' message on the top of the LCD panel flashed '81'. I did all sorts and to try to get it going since I didn't bring out the other card. I only stopped short of formatting it.

One week later and reading through tons of forums, reviews and Q&A. I did this.
1. D/L WinHex at http://www.winhex.com
Made an image of the SM card onto the hardisk.

2. D/L jpegdump at http://www.goto.onlinehome.de/dsc/jpegdump.htm
Used the -recover option it to sift out the pics on the the card. It takes about 30mins to complete 64MB of data.

Note: Always make an image of the card to the hardisk and then work on the image of the card. Not on the card itself. Also, read the instructions. jpegdump is a command line executable in DOS mode. The -copy option didn't work for me so I used WinHex to make an image of the card.

Lastly, the easiest way but most risky is:
1. Used Norton Disk Doctor to diaganose and repair the disk. Remember to create an undo file - just in case. After fixing and FAT and sorting out the lost clusters and saving the lost clusters, the pics magically appeared on the card again. (Using the card reader and Windows Explorer).

I was happy and yet annoyed that I had spent half a day on a simple solution. Of course using Norton Disk Doctor could have destroyed the card for good. Nonetheless, I discovered other aspects of data recovery - nothing is really deleted and we can really dig up old trash, so Beware.

By the way, this method is for corrupted cards only and not for accidentally deleted pics.

Hope it helps and havefun!

whoareyou639 is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:08 PM.