Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Aug 7, 2007, 11:44 PM   #1
Junior Member
Join Date: Aug 2007
Posts: 2

I just got one of those new photo frames that display pictures from a memory card. I formatted over 200 images and saved them as jpg files. The 200 images take up approximately 24 mb of space. When I tried to save the images to a SanDisk 1 GB SD card, I was only able to save 150 files.

I should have enough room on the 1 GB SanDisk to store several hundred photos. Why is it that I can only transfer 150 images onto that disk?

Also...I also tried saving the same 200 or so images to a Compact Flash disk with the same results. Both the SD card and the CF were purchased at a legitimate electronics store and should be real and not forgeries. What am I doing wrong here?

Thanks for your advice.
camera_ready is offline   Reply With Quote
Sponsored Links
Old Aug 8, 2007, 6:31 AM   #2
Senior Member
Sintares's Avatar
Join Date: Jul 2005
Posts: 647

As far as I am aware there is a limit to the number of files placed directly into the root of the cards due to the file system the card is created with.

So, create a folder on the card, drag and drop or copy the files into that.

If that fails then create a few folders and divide the pictures between them.

Sintares is offline   Reply With Quote
Old Aug 8, 2007, 7:07 AM   #3
Senior Member
TCav's Avatar
Join Date: Sep 2005
Location: Washington, DC, Metro Area, Maryland
Posts: 13,394

Where and when did you last format the card? If it was last formatted in a camera, format it again in your computer, and try again.
TCav is offline   Reply With Quote
Old Aug 8, 2007, 8:17 AM   #4
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,369

What do you mean by "transfer"?

Are you using Windows Explorer to copy and paste the files, or are you using some kind of program to do it?

What kind of error do you get when it stops copying?

As mentioned by Sintares, there is a limitation on the number of entries in the root, depending on the file system (it's probably FAT16). This is normally 512 entries. But, if you're using long filenames with Windows (anything other than an 8 character filename + 3 character extension), it's going to use more of the entries.

That's one reason camera manufacturers don't use long filenames (better compatilbility with more file systems and utilities). So, they typically use filenames that look something like DSC_1234.jpg or pict1234.jpg (8 characters + a 3 character extension).

If that's your issue, as already suggested, place the files in folders versus in the root directory if your device can find them there. If not, and if your picture frame supports FAT32, you could reformat the cards that way using Windows (select FAT32 from the drop down file system type list). Windows usually formats a removable memory card this way by default. But, make sure by looking at the file system type when you use Format.

But, be advised that many camera models are *not* FAT32 compliant (the cards won't work if formatted that way in a number of cameras). I can't tell you the number of posts I've seen from users asking asking why their card won't work in their camera anymore after they formatted it with Windows (quite a few). lol

So, depending on the camera model, you'd need to reformat the cards using the file system type of FAT from the drop down file system type list with Windows if you wanted to use it again in a camera. It's a good idea to reformat the cards using the camera's menu choice for format before using one again if you do that.

Also, it's a good idea to use the "Safely Remove" icon in your system tray if one exists before removing any card from a reader that you write to with Windows (to prevent corruption, because some drivers will cache writes to media by default).

The easiest way is going to be the way already suggested earlier in this thread. Copy the files to folders versus the root directory on the card if your picture frame can find them that way.

JimC is offline   Reply With Quote
Old Aug 8, 2007, 12:27 PM   #5
Junior Member
Join Date: Aug 2007
Posts: 2

Thank you all for your excellent advice!

Sintares, I did as you said and created a new folder. That solved the problem. I didn't realize that the root had those limitations. As an experiment, I also created different folders. When the photo frame device is playing in random mode, it bounces back and fourth between folders and seems to be working properly. So it looks like either method works. Thanks.

TCav, none of the cards used had been formatted on a camera, although I can see why that could create issues.

JimC, I'm using Mac OS 10. When I said "transfer" I basically meant that I copied the files onto the card. With Macs we don't have "safety remove" but it is advisable to move the Icon of the card reader into the trash before removing the device to avoid possible file corruption.

Thanks again guys!
camera_ready is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:09 PM.