Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Aug 24, 2003, 9:41 PM   #1
Junior Member
Join Date: Aug 2002
Posts: 2
Default F error on Olympus SmartMedia

I have an Olympus c3040Zoom.
Olympus batteries recently died and effected my Olympus 64MB SmartMedia card. When I turn the camera on, I get a "F" error on the display, which means the card needs to be reformatted.

I have 70+ vacation snapshots on the card & I want to retrieve.

I've read that Photorescue is a preferred recovery tool for the Mac OS 10.2.6 platform. When I run Photorescue in demo mode, the damaged card does not show up in the mounted disks window. A blank card inserted into the camera shows up as a mounted disk.

I am VERY reluctant to reformat the bad card to let the tool see if it can recover the photos.

Any advice is very appreciated.

redfox85 is offline   Reply With Quote
Sponsored Links
Old Aug 25, 2003, 3:39 AM   #2
Senior Member
Join Date: Aug 2002
Posts: 2,162

Some of the recovery software vendors offer a recovery service if their software doesn't work. First they will 'image' your card, bad format and all. Then probably using specially written DOS tools they will access the data areas on the card, not through a USB reader, but probably a pcmcia or IDE interface.

If you want to try it, most camera formats don't do a proper format writing zero's across the card, so it should be possible to try an in camera format then immediately run Photorescue. Test this out by taking a good card with images on it, re-format it in cam and see if the images are recoverable. Unfortunately if the master boot record or FAT table is corrupt, your first problem will be getting the card recognised as valid media. VOX
voxmagna is offline   Reply With Quote
Old Nov 22, 2004, 11:43 PM   #3
Senior Member
digcamfan's Avatar
Join Date: Jul 2002
Posts: 3,422

Remove and reinsert your smartmedia card several times.

This may remove the F error.

It did for me on an old C2100 UZ.

digcamfan is offline   Reply With Quote
Old Dec 1, 2004, 12:58 AM   #4
Junior Member
Chris Combs's Avatar
Join Date: Nov 2004
Posts: 28

Old thread!

When cabled directly to the camera, damaged cards often don't mount; but when using a card reader, the operating system is given more direct access to the card - and as such is allowed to determine for itself whether the card's format is valid, which allows recovery utilities to work. (When plugged into the camera directly, if the camera can't read the card, it reports to the OS that no card is inserted. Cardreaders report the card whenever it is physically present and operating.)
Chris Combs is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 9:59 AM.