Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Mar 20, 2008, 9:21 PM   #1
Junior Member
Join Date: Mar 2008
Posts: 1


I've been going over other threads in your forum, trying to find a way to fix my XD card, but none of the suggestions in the other posts seemed to work. Hopefully you can help me too...I'm desperate, so thanks in advance for any suggestions!

(I have a brand new olympus fe-230 with a brand new xd card and a bunch of pics on it. I'm now using an XD card reader to try to view and recover my lost pictures, with no luck.)

Naturally, halfway thru my vacation, the camera all of a sudden said 'card error' and shut off.

When I turned it back on, it was clear that there were still pictures (or data, at least) still stored on the card, since the amount of space left was a fraction of the total card capacity, but I was not able to view those pictures, at least using the camera.

I was able to take more pictures that day. The next day, I went to an internet cafe, used a card reader and found that my pictures prior to the 'card error' message were stored in a different folder.

When viewed from 'my computer' my card shows 2 different folders:
- 'DCAE(' with a subfolder '100OLYMP' wich has another 2 subfolders, as well as my pics prior to the 'card error' message
- 'DCIM' has a subfolder '100OLYMP' also, with the pics after the 'card error' message

The DCAE( folder has the normal 100OLYMP folder, and when that's opened, random pictures are visible, and random ones are not able to be opened.

The non-readable/viewable pics have a .BPG file extension. There doesn't seem to be any order, since there are 2 good pics, then 3 bad files, then one good pic, then 2 bad files, etc.

Also, there are 2 more file on that same tree:
- &
(not sure if that means any thing, but when they're opened, it shows the same file as the parent folder.)

The other folder:
-DCIM, is fine.... it has the 100OLYMP folder with the rest of my pics in it, and seems that has all of those pics (that were taken after the 'card error' message) are fine.

I'm actually able to view these from the camera, and save or erase them, and take more. But I can't view the others from the camera, although they are still there, readable or not.

I've tried the pc inspector, that said there were no files to fix. But 'my computer' shows there are definately files there.

I also tried cg security, but I keep getting ms-dos windows that lead to nowhere. I'm probably following the wrong prompts on that one...

Please help, if you can!

(I promise that if I can get my lost pictures back, I will drive over this piece of sh_t camera with my Jeep, put it in an envelope, and mail it back to Olympus, with a fantastic review of their product. No joke.)

Thanks so much!
breebauer is offline   Reply With Quote
Sponsored Links
Old Mar 21, 2008, 5:31 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,372

breebauer wrote:
I'm actually able to view these from the camera, and save or erase them, and take more. But I can't view the others from the camera, although they are still there, readable or not.
Don't do that (write to the card in any way, including erasing, new photos, etc.), or you'll risk damaging any recoverable images that haven't been overwritten yet.

Which PC Inspector did you try? You'll want to use the Smart Recovery product (not the PC Inspector File Recovery) for a badly corrupted FAT (File Allocation Table), which is probably your issue with duplicate folder names showing up, etc.). It's this one:


As for Photorec (I assume that's what you meant by cgsecurity), it's pretty simple to use. It's very good software for recovering images from corrupted media. You will have to maximize the command window (make it larger) to see the menu choices. Make sure you're using photorec and not testdisk (they're in the same download).

Here's a page showing you how to use it:


If you have any questions or issues or get stuck at a menu choice, just let me know and I'll try to talk you through it. You're going to leave everything at defaults except for the choice to pick your memory card. The rest will stay at their default choices (partition table type, etc.), unless you want to change the folder you're saving images to (it will default to storing recovered images in subfolders under where it was started from if you don't pick another folder on your hard drive to save them to).

JimC is offline   Reply With Quote
Old Jun 19, 2008, 8:21 AM   #3
Junior Member
Join Date: Jun 2008
Posts: 1


I'm having a similar problem in that I bought a new XD 512 memory card, as a replacement for a lost 128. I have been using it in the same camera as the previous card and transfering the photographs to my computer using the memory card reader that is installed on my laptop. I have all my photos on my computer, but they are not registering on the card. I have had no "card error" messages nor any files that have been corrupted (as far as I can tell). However, my memory card thinks it is full, yet when I attempt to replay the photos it gives the message "no picture".

Should I format my card? I've attempted to go through the computer to delete the files, but it says that my card is write protected and cannot delete them this way! Please help, I need my camera to take photos of graduation next week!! Thanks!
Saz is offline   Reply With Quote
Old Jun 19, 2008, 8:34 AM   #4
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,372

If you're sure you don't need to get anything else from the card, try formatting your card using your camera's menu choice for format (not your PC). Personally, I reformat my memory cards like that prior to every reuse. I also try *not* to delete photos using a PC, since that is writing to the card, and if a card is removed while any writes are in the PC's cache, you can corrupt the File Allocation Table. So, make sure to use the Safely Remove feature for any card readers before removing a card after you've written to one in any way.

If you can't format your card using your camera's menu choice for format (for example, if you get an error that it can't be formatted), then try it with a PC. But, make sure to select FAT from the drop down list of file system types, provided your card is not larger than 2GB. Otherwise, Windows will default to FAT32, which is not compatible with a lot of cameras. Then, I'd suggest formatting it with your camera's menu choice for format before using it again.

JimC is offline   Reply With Quote
Old Jun 19, 2008, 10:10 AM   #5
Senior Member
Join Date: Jan 2007
Location: Decatur, GA
Posts: 2,052

I had a similar issue with an old 512MB card I was using in my old Fuji S5100 or was it a 5200....... in the early 2007 time frame. I could see the images in the camera and got the card error message at about 70 pictures. I was on a very important photo shot without a spare card at my side sosince I could still shoot and have the images show up on the screen I tool 5 more. but only about 30 of the 75 or so pictures uploaded to the camera before it stalled. I used both card reader and camera connection.

What I found worked for me was to load the card via USB card reader and used a program called photorecovery I got off the internet (costs somw money but it works the 5 times I have had to use it 4 times for deleting images I wanted to save before they were saved. When the card shows up under my computer launch the program and run the program and go have a long dinner as it will take a while to extract everything. Then save the ones you need.

I also found out that when I reformatted the card the problem keep coming back so I got rid of the card. I now use a 1GB xD card from olympus in my Fuji S9100 as a backup to my CF cards.

Hope this helps and hope you can get the pictures you want to save

Photo 5 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 5:21 PM.