Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Jul 21, 2009, 6:42 AM   #1
Senior Member
Join Date: May 2006
Posts: 181
Default Problem with SD slot on Sandisk 12-in-1 SDDR-89

I'm having trouble with the SD slot on the 12-in-1 with having to sometimes insert the card multiple times to get it to recognize. The green light comes on every time. This is a brand new unit that was given to me by SanDisk as a replacement which was returned for the same exact reason.

The SD only SDDR-99 never let me down.

Anyone else?
itsme000 is offline   Reply With Quote
Sponsored Links
Old Jul 21, 2009, 9:11 AM   #2
Join Date: Jun 2003
Location: Savannah, GA (USA)
Posts: 22,367

Have you tried a different Secure Digital Card? A card that's not recognized intermittently can mean a failing component. I'd also make sure to reformat the card (preferably using your camera's menu choice for format) in case it's corrupted in some way.

Have you tried the card reader on a different PC (in case you have a problem with your USB port or it's drivers)?
JimC is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 8:22 AM.