Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Jan 16, 2012, 9:04 PM   #1
Junior Member
Join Date: Jan 2012
Posts: 1
Default Old Fuji S602Z CF "card will not initialize" problem


I'm not sure if there are any of you still left out there, but I have a Fuji S602z that I dusted off and I'm trying to get going. I had a 512MB trancend CF card in it, which I know for sure was working 7ish years ago. The card saw very light usage over the years.

Anyway, I popped in the Trancend card after a quick dust off and tried to format it. The camera formatted the card and then gave me the error "card will not initialize". Ok fine. So, I went out and bought a San Disk CF card (2GB w/ fast R/W speeds - a high end card). I popped it in, formatted it and again the camera gives me the error "card not initialized".

So, I take the San Disk card and format it with regular "fat" on win7, which so far as I know is "fat 16", hoping to bypass the format procedure on the camera. The camera still does not recognize the San Disk card "card not initialzied".

I'm getting the feeling that something is messed on the Camera. It does have a smart media slot, which is ok I guess. Can the firmware on these cameras be re-flashed? The CF slot pins are not bent at all. Is it worth trying a 3rd brand of CF?

amiga1200 is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:01 PM.