Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Feb 22, 2005, 3:06 AM   #1
Junior Member
fuzzyfusion's Avatar
Join Date: Feb 2005
Posts: 2

Magicstor 4GB ATA/IDE does not works on the Cameras. Any suggestion how to make it work or suggest some alternate use of this drive.:?
Attached Images
fuzzyfusion is offline   Reply With Quote
Sponsored Links
Old Feb 25, 2005, 10:37 AM   #2
steve's Avatar
Join Date: Jun 2002
Posts: 2,535

Not familiar with that brand but your camera must support FAT32 to use a device with more than 2GB of capacity. What camera are you trying to use it in ? See my IBM / Hitachi Microdrive report, there is a list of known cameras with FAT32 support.

I don't know what their quality level is these days but earlier Magicstor Microdrives were less than satisfactory when used in digicams. I think most of them are being sold for use in MP3 players these days. If you must have a Microdrive I would highly recommend the Hitachi brand, they just announced a new 6GB drive that will be shipping very soon for $299.

Did a little more digging and found that GS Magicstor has two different 4GB drives, the one you have with an ATA-IDE interface and a 4.4GB drive with a CF-II interface.I suspect that your drive will not work in any camera - you need the CF-II interface of the 4.4GBmodel.


It should work fine if used in a computer though as it does have an ATA-IDE interface.

steve is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:15 AM.