Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Aug 8, 2005, 9:04 AM   #1
Junior Member
Join Date: Aug 2005
Posts: 1

Hi. I, too, am having a similar problem and I hopethere isa solution. I was happy to seeNWW posting describing what proceduresthey tried to gettheir card to work - it saved me time and trouble. I have a Canon G3, using a Dane-Elec 256 mg CF card. Never a problem, 1000's of photos. Was on a camping trip Saturday, and after taking several photos, all of a sudden it said "CF Error". The camera wouldn't turn off, then wouldn't turn on - acting bizarre, like the battery wasn't working, but it was fully charged. I messed with it some more, took card out and put it back in, saw the CF error again and again, finally got it powered off and put it away. I tried it in my USB Card Reader at home, system doesn't see the CF card. I put another CF card in the camera, the camera works fine. Prior to the trip I had erased all images on card. One thing I didn't do was re-format the card in the camera. I have some beautiful photos on the card, nothing absolutely crucial, but I would like to recover them if possible. If recovery is not possible, how can a card be reformatted (would this help at this time) after one gets a CF error and nothing seems to recognize the card? Is the card dead at this point? I don't want to scrap it until I know for sure it's beyond help. Any help or suggestions would be appreciated. Thanks. ShirleyW
ShirleyW is offline   Reply With Quote
Sponsored Links

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:33 PM.