Go Back   Steve's Digicams Forums > Digicam Help > Memory Cards, Microdrives, Card Readers

Thread Tools Search this Thread
Old Mar 23, 2003, 2:24 PM   #1
Junior Member
Join Date: Mar 2003
Posts: 2
Default camera /compact flash problems?

My S100 powershot cannon is around 2 years old. I bought a 64mb compact flash card FUJI around a year ago replacing the 16mb CF cannon card.

Since then every so often (about every 10 fill ups of the card) I loose all the pictures on the card - and now it is happening more frequently. (sometimes I can get half a dozen pictures out of a 100 that i've taken, and the card shows the space is used up to 50 - 56 mb)

3 questions.

Is it more likely to be problem with the camera or the card?

Does anyone else have these problems?

If I buy a new card which one should I buy?

Thanks in advance for any help

joel-london is offline   Reply With Quote
Sponsored Links
Old Mar 24, 2003, 5:46 PM   #2
Senior Member
Join Date: Aug 2002
Posts: 2,162

When you 'fill a card' - are you doing a reformat in the cam each time?, you should do, to prevent fragmentation of the storage space.

You could check the default cluster size your 16Meg card is formatted to, it's probably 2040 bytes, whereas the 64meg card may be 4 or even 8k. Using Win2K you can reformat a card as 16 bit FAT and choose your cluster size. This is a last resort. I think your problems sound like fragmentation, stuff is not being cleaned off the card.

I know some manufacturers like Oly put a few special format bytes on their own cards, but generally if you use oems or non-Oly cards you only loose pano shot mode. Check in the Cannon section if Cannon cards are anything special format wise.
voxmagna is offline   Reply With Quote
Old Mar 24, 2003, 7:10 PM   #3
Junior Member
Join Date: Mar 2003
Posts: 2

Thanks Voxmagna.

I don't reformat everytime in the cam - so I will start doing that - and it only ever does it when the card is nearly full, i also feel that flipping from "preview" mode to "shoot" mode may influence it, but i can't deliberately create the error.

i'll browse the cannon section as you sugested and see what i can find.

thanks again

joel-london is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 11:36 AM.