Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Thread Tools Search this Thread
Old Feb 23, 2009, 9:11 PM   #1
Junior Member
Join Date: Feb 2009
Posts: 2

Hi. My husband purchased a Canon Rebel XS DSLR for me as a Valentine's Day present. I have had a regular Canon Rebel SLR for about6 years and was pleased to see that the functionalities were pretty much the same.

I pretty much use the automatic features as I'm still intimidated by stops and aperatures and all that jazz!

I tried both of my Sigma lenses (a 28-80 and a 70-300 DL) The 28-80 worked fine and didn't seem all that different from the Canon 18-55 that came with it. The 70-300 is a bit more....welll recalcitrant. I've used it indoor with what I felt was adequate lighting and outdoor in low light....ok...barely any light.

Both times the lens seemed to havetrouble focusing...made lots of noise and telescoped in and out and never would snap a picture. I've scoured the net and have seen that some people have had the same problem but haven't found an answer for why.

Can anyone offer an explanation or fix?
agrizzaffi is offline   Reply With Quote
Sponsored Links
Old Feb 24, 2009, 7:55 AM   #2
Join Date: Aug 2004
Posts: 8,528

Indoors or outdoors in low light I would expect the 70-300 to have trouble. Heck, my Canon 100-400 at 7x the cost has trouble focusing in low light. Most 5.6 lenses will have trouble - add to that it's a budget telephoto I don't find it unusual. That is not a low light lens - so even though you probably don't want to hear this - the advice is don't try to use it in low light.
JohnG is offline   Reply With Quote
Old Feb 24, 2009, 3:16 PM   #3
Senior Member
NHL's Avatar
Join Date: Jun 2002
Location: 39.18776, -77.311353333333
Posts: 11,331

This may be not what you want to hear, but when you get an external flash, the flash will emit infrared beams (similar to the ones @ the checkout counters) which will help the camera focus in low-light when you 1/2 press the shutter

Also is low-light the camera will emit a series of 'AF-assist' flash pulses to help the camera to focus if you don't want to invest in an external flash
NHL is offline   Reply With Quote
Old Feb 24, 2009, 6:11 PM   #4
Junior Member
Join Date: Feb 2009
Posts: 2

Thanks so much for the info. As I said, I pretty much stick to my smaller lenses and haven't had much use for the 70-300 except outdoors in good light. Tested it again just now outside with ample light and all seems well.

Think I need to do some more reading before I go snapping pictures.

Thanks again.
agrizzaffi is offline   Reply With Quote
Old Mar 30, 2009, 5:37 PM   #5
Senior Member
deterpawson's Avatar
Join Date: Jan 2007
Posts: 393

i have a sigma 28-200mm lens which i use on film camera, a canon eos 7e
the lens works fine on my film camera
when attached to my canon rebel xsi the focus is very soft and some out of focus completely
apparently the 'chip set' on sigma lenses 5yrs or older are incompatable with the newer technology and you have to send gthem back to sigma to be 're-chipped'
however sigma does have parts to do this anymore or at least that was the response they sent me
send sigma an email with the serial number of your lens and see what kinda response you get
hope this helps
deterpawson is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 6:21 PM.