Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Thread Tools Search this Thread
Old Oct 30, 2011, 7:24 AM   #1
Junior Member
Join Date: Oct 2011
Posts: 2
Default Canon SD 750 - 'No Image' tho' images are there?!

Hallo, I have a Canon SD750 ELPH and have enjoyed using it for a couple of years. I had no trouble uploading pictures to my PC with a USB Cable. Yesterday, I took some pics (which I can view easily on the camera) and went to upload but once connected to my PC. the camera screen went black and 'no image' came up. I disconnected the camera & PC and the images could again be viewed on my camera. I've tried different ports, a different cable, the battery is fully charged and have not changed anything. I cannot figure this out as the images are viewable on my camera, but seem to be lost once the Pc is connected. I would appreciate any help and ideas. Many thanks!
Supersnapper is offline   Reply With Quote
Sponsored Links
Old Oct 30, 2011, 8:45 AM   #2
Senior Member
Join Date: Jan 2007
Location: Decatur, GA
Posts: 2,050

make sure if the images got stored to thr internal memory by mistake that you connect the camera to the computer without a memory card in it. Try that she sheee if the images come up

Photo 5 is offline   Reply With Quote
Old Oct 30, 2011, 9:25 AM   #3
Junior Member
Join Date: Oct 2011
Posts: 2

Hi Dave - thanks for taking the time to try and help me with this.
I've tried taking the card out and reconnecting to the PC but then the message just says 'no memory card', and I cannot see any of the shots, whether the camera is connected to the PC or not. Does this camera have an internal store? Thanks
Supersnapper is offline   Reply With Quote
Old Oct 30, 2011, 11:14 AM   #4
Senior Member
BillDrew's Avatar
Join Date: Jun 2002
Location: Hay River Township, WI
Posts: 2,512

Try the standard high tech problem solving technique: "Swap parts".

Is your computer able to see a thumb drive connected to the same USB port? Does connecting to a different port solve the problem. A different cable? A different computer?
BillDrew is offline   Reply With Quote
Old Oct 30, 2011, 11:33 AM   #5
Senior Member
VTphotog's Avatar
Join Date: Mar 2005
Location: Extreme Northeastern Vermont, USA
Posts: 4,165

Are you able to take new pictures and view them on the camera? This will tell you if the memory card is damaged.
Do you have access to a card reader? This should allow you to access the images on the card. Once you have uploaded the pictures to your computer, put the card back in the camera and format it. Memory cards are like hard drives, in that they can become fragmented or corrupted, and the best way to use them is to format them after uploading pictures, each time you do.

VTphotog is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 1:34 PM.