Go Back   Steve's Digicams Forums > Digicam Help > Newbie Help

Thread Tools Search this Thread
Old Dec 4, 2005, 10:39 AM   #1
Junior Member
Join Date: Dec 2005
Posts: 1

Yesterday, I recieved a new Praktica DCZ 5.4 Digital Camera. After using the camera about 4 times it started claiming that the battery had run down and automatically switching off. I then inserted new batteries, but the same thing happened.

Does anyone know what is going wrong? (It is very annoying) :angry:
Vivi1993 is offline   Reply With Quote
Sponsored Links
Old Dec 4, 2005, 4:20 PM   #2
Senior Member
Join Date: Aug 2002
Posts: 851

That camera uses AA batteries. You did not say what kind of batteries you are using. But based upon what you said, it sounds like you are using disposable (ie: non rechargeable) batteries.

If so, that is probably the problem. Rechargeable batteries are much more capable of meeting the power requirements of digital cameras. Alkaline, or worse, carbon-zinc, just cannot supply sufficient power and become exhausted very quickly.

I suggest you get some NiMH AA batteries of a high capacity, plus a good charger.

amazingthailand is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:41 PM.