Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Sep 5, 2006, 6:57 PM   #1
Junior Member
Join Date: Feb 2006
Posts: 11

I was photographing some paint colour swatches placed on a white paper background. The white paper comes out as blue! Not a pale blue, but quite an intense blue. The photo was taken in daylight, but not in direct sunlight. When I repeated the process using flash, the paper was much closer to white, but still slightly grey. I then placed my lens cap on the white paper and took a photo - once again, the white paper came out as very blue.
My white balance was set to automatic; I did not try changing this to any other setting. P mode was selected.
Later I photographed the same colour swatch under fluorescent light (still with automatic white balance); this time the white background appeared as aqua! With WB changed to fluorescent, the white was still aqua! I have tried to attach a copy of this last photo.
What is causing this problem? I don't believe that I have messed up any colour settings. Any help would be appreciated.
Attached Images
Fifer is offline   Reply With Quote
Sponsored Links
Old Sep 6, 2006, 12:22 AM   #2
Senior Member
rjseeney's Avatar
Join Date: Dec 2004
Location: Taylor Mill, Kentucky
Posts: 2,398

I can't view the EXIF data for the pic you posted, but based on what I see, it looks as if the flash fired. Typically, light from the flash causes a bluish cast. The light from the flash was the main light (or at least the stongest light in the room), and since light is very reflective, you get a stong bluish cast. You mention one of the pics had a greyish cast. Most light meters meter off a base point of 18% grey. When photographing a frame that is mostly white, the camera assumes 18% gray and underexposes the image giving it a gray like appearance. Cameras struggle with mostly white images.

You can avoid the color cast by using custom white balances, or shooting RAW, which allows you to fine tune the image without the cameras help.
rjseeney is offline   Reply With Quote
Old Sep 6, 2006, 11:55 AM   #3
Junior Member
Join Date: Feb 2006
Posts: 11

Thanks for the reply. No flash was used for this photo, which was taken under fluorescent light. The EXIF info is listed below.
File: - C:\Documents and Settings\Allan\My Documents\My Pictures\Colour test\Colour test 023.jpg

Model - NIKON D50
Orientation - Top left
XResolution - 300
YResolution - 300
ResolutionUnit - Inch
Software - Ver.1.00
DateTime - 2006:09:05 19:34:26
YCbCrPositioning - Co-Sited
ExifOffset - 216
ExposureTime - 1/20 seconds
FNumber - 4.80
ExposureProgram - Normal program
ExifVersion - 0221
DateTimeOriginal - 2006:09:05 19:34:26
DateTimeDigitized - 2006:09:05 19:34:26
ComponentsConfiguration - YCbCr
CompressedBitsPerPixel - 4 (bits/pixel)
ExposureBiasValue - 0.00
MaxApertureValue - F 4.59
MeteringMode - Multi-segment
LightSource - Auto
Flash - Not fired
FocalLength - 35.00 mm
UserComment -
SubsecTime - 0
SubsecTimeOriginal - 0
SubsecTimeDigitized - 0
FlashPixVersion - 0100
ColorSpace - sRGB
ExifImageWidth - 3008
ExifImageHeight - 2000
InteroperabilityOffset - 21458
SensingMethod - One-chip color area sensor
FileSource - Other
SceneType - Other
CustomRendered - Normal process
ExposureMode - Auto
WhiteBalance - Auto
DigitalZoomRatio - 1 x
FocalLengthIn35mmFilm - 52 mm
SceneCaptureType - Standard
GainControl - None
Contrast - Normal
Saturation - High
Sharpness - Normal
SubjectDistanceRange - Unknown

Maker Note (Vendor): -
Data version - 0210 (808595760)
ISO Setting - 200
Image Quality - FINE
White Balance - AUTO
Image Sharpening - AUTO
Focus Mode - AF-A
Flash Setting - NORMAL
Flash Mode -
White Balance Adjustment - 0
Exposure Adjustment - 68608
Flash Compensation - 67072
ISO 2 - 200
Tone Compensation - AUTO
Lens type - AF-D G
Lens - 638
Flash Used - Not fired
AF Focus Position - Top
Bracketing - 65536
Color Mode - MODE3a
Light Type - NATURAL
Hue Adjustment - 0
Noise Reduction - OFF
Total pictures - 640
Optimization - CUSTOM

Here is another example of a photo showing the strong blue in place of white. This was taken in daylight (but not direct sunlight) with no flash. I think the EXIF info should still be readable using IrfanView.

Attached Images
Fifer is offline   Reply With Quote
Old Sep 11, 2006, 2:43 PM   #4
Join Date: Apr 2005
Posts: 52

Looks like the white balance is off, easy to fix in Photo Shop or other programs. I think you needed to set it manually.
miatapaul is offline   Reply With Quote
Old Sep 11, 2006, 4:45 PM   #5
Junior Member
Join Date: Feb 2006
Posts: 11

I appreciate your reply.
My next question would be: "Isn't the setting 'auto white balance' supposed to take care of situations like this?"
I realize that this is a bit of an artificial situation - a black object on a white background, but why do I end up with a bright blue background? Perhaps I am expecting too much, but I have not seen anything that says when I take a photograph with a white background, I have to make adjustments in the camera to make sure the background is not blue. Rjseeney's reply came closest, but I did not use flash. I can see his point about the 18% grey, but I get a grey background with flash.
I use Paint Shop Pro X as my photo editor, and although I can make some adjustments, I can't seem to get the background pure white. I guess I still have lots to learn about my Nikon.
I would be interested in knowing if my experience is typical with a Nikon D50. Has anyone repeated this "experiment"? Take a photo of your lens cap (or any black object) on a white background (sheet of paper) in normal daylight - what does your photo look like?
Thanks again.
Fifer is offline   Reply With Quote
Old Sep 12, 2006, 2:24 AM   #6
Senior Member
Join Date: Mar 2005
Posts: 215

I would agree. I have noticed the same thing with my D50. I wonder if the auto white balance algorithm thinks it is a blue sky? Don't do any wedding dress close ups on auto though:?


Fifer wrote:
I appreciate your reply.
My next question would be: "Isn't the setting 'auto white balance' supposed to take care of situations like this?".
keith1200rs is offline   Reply With Quote
Old Sep 12, 2006, 10:51 AM   #7
Nagasaki's Avatar
Join Date: Jan 2004
Posts: 897

The colour temperature of daylight varies greatly during the day. It's warm and would quite probably cause an red or orange cast at sunrise and sunset. At mid day it's quite blue and more so under cloudy skies or in the shade.

Auto WB tries to analyze the picture and determine what is white. Once you have white correctly set the other colours fall into place. In your shots you're not giving the algorythm much of a clue and it's got it badly wrong. My preference is to set the WB in the Photoshop RAW convertor in post processing. If shooting JPG I'd set the WB on camera to the most appropriate setting rather than relying on auto.
Nagasaki is offline   Reply With Quote
Old Sep 14, 2006, 4:55 PM   #8
colasteve's Avatar
Join Date: May 2004
Posts: 74

Don't use Behr paint, it's over priced HD crap that does not go on that great.


colasteve is offline   Reply With Quote
Old Sep 20, 2006, 8:12 PM   #9
Senior Member
monx's Avatar
Join Date: Feb 2006
Posts: 107

i hvae had the same problem only my white walls come out red??

this is also with Auto whitebalance.
monx is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 12:35 PM.