Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Mar 8, 2007, 12:48 AM   #1
Junior Member
Join Date: Jan 2006
Posts: 4

There is a very long thread on the Nikonian forum about a D80 problem in which the battery indicator one moment will show that the battery has plenty of juice and then the next moment will show that the battery is low or almost dead. Resetting the camera fixes this issue, at least temporarily until it happens again. Theories on it have been that it's the lens and other theories have floated around. One or two people said they have sent their cameras back to Nikon and they came back without the problem. At least one or two people said they sent their cameras back to Nikon and they came back with the same problem. To my knowledge, Nikon has not even acknowledged any problem. On the other forum, someone said that since only 26 people since November have reported the problem (on that particular forum), that it's not very widespread. I think 26 people on just one forum is really a lot for the same problem. I was considering buying a D80 and now I'm scared that I will become a statistic in having the problem. If Nikon said there is a problem and indicated that they are working on it, I would not be scared. But I thought I would put the issue out on another forum and see if people who perhaps use this forum but not the other one have the problem. I know I can't canvass enough people to really get a statistically significant conclusion but at least by putting it out here, I will get some more data on how widespread the problem really is. I mean, would you buy a car that you knew a bunch of people were reportingthe sameproblem with it's operation over?

Thanks for your feedback. I am not trying to stir up any trouble of bad mouth Nikon in any way. I am just trying to determine if it is wise to buy a D80 while this problem appears to be outstanding in more than just a couple of units.

Goldberg96 is offline   Reply With Quote
Sponsored Links
Old Mar 8, 2007, 6:35 AM   #2
Senior Member
ReneB3's Avatar
Join Date: Jul 2005
Posts: 193

I have a D80, and an early one at that, and have never had any battery issues. I have followed the Nikonian thread as well and it looks like the issue is with the early models, and not really affecting that many units considering how many they made and sell. I think any complex device will have issues with a few per million and it's the internet/mass media age that tells us of each failure. We never hear from the masses who have no trouble and keep smiling with their D80 in hand.
ReneB3 is offline   Reply With Quote
Old Mar 16, 2007, 1:50 PM   #3
Senior Member
DocX's Avatar
Join Date: Oct 2004
Posts: 114

Ive had no problms with mine.
DocX is offline   Reply With Quote
Old Mar 28, 2007, 11:14 PM   #4
Junior Member
Join Date: Mar 2007
Posts: 1

I am having this problem with my D80. It happened very infrequently at first, but now is a regularly recurriing pain in the butt, especially if you want to get off a quick snap and the camera doesn't power up.I looked on Nikonian and really couldn't find much discussion there, other than suggestions to send it off for repair. I use my D80 5 or 6 days a week, 100 plus shots at a time, so I don't want to give it up for repair (which I hear can take a month). Any comments or suggestions?

racquet364 is offline   Reply With Quote
Old Mar 30, 2007, 7:36 AM   #5
Join Date: Jun 2006
Posts: 51

Mine works ok with no battery issues.

mansell is offline   Reply With Quote
Old Mar 31, 2007, 5:56 PM   #6
Senior Member
Join Date: Jul 2004
Posts: 226

My battery did not seem to last too long when i first got the camera, but after about the third charge, it started to hold the charge better.

When my battery starts to weaken, I get loads of advanced warning as the battery indicator shows half power, quarter power etc in slow stages.
norm smith is offline   Reply With Quote
Old May 7, 2007, 6:43 AM   #7
Junior Member
Join Date: May 2007
Posts: 1

I also have same problem as yours. One of my friend have also same problem and now it is broken(mirro lock). I'm afraid of it now. I think we should do something. I'm sending complain to Nikon.
miikhaa is offline   Reply With Quote
Old May 7, 2007, 8:51 PM   #8
TexasHillbilly's Avatar
Join Date: Jun 2006
Posts: 62

I have a D80 andI have not used it enought to know, I am on my 2nd charge, the first one lasted about 540 pics, but i was playing and expermenting alot with it. Right now I have 571 pics on this charge and the meter shows it to be @ 71% still.

I have read that alot of people are getting better performance after a few charges.

I also have a D50 and I usually average around 1500-2000 pics per charge on it.

I think if i had the problem I would send mine in for a fix ASAP

TexasHillbilly is offline   Reply With Quote
Old May 15, 2007, 4:39 PM   #9
Junior Member
Join Date: Apr 2007
Posts: 8

Owning a D80, threads like this could be of interest to me... Just yesterday I was asking about using replacement batteries instead of paying the "Nikon" price for a "Nikon" battery. I mean, you can get them for about a half to a third the price and they apparently can have a slightly better output, maybe giving longer use,, BUT,, somebody replied that replacement batteries wont have the chip in them which gives info to the camera about battery life...

Click, clack, ding (those are the cogs inside my head - turning while thinking of an answerto this problem)...


Batteries - Battery life - False readings.... Could this bea battery fault, or, something to do with the info sent by that chip in the battery, or, a software problem..???

Possible solutions...

1. Update you firmware if you have version 1.00- The latest is version 1.01...

2. Try one of those replacement batteries I was thinking of trying myself. Now, if they don't have that chip in them to linkup to the camera, then maybe the sensor wont get confused. Maybe you might get more life and maybe you wont suffer any of those related problems. Of course, youwont be able to see how much life you battery has left but you should be able to afford at least 2 or 3 of them for the same price as one genuine one,so you can carry a spare or2around in your pocket...

So far, from what little I have read of this problem, it seems to pointmostly to the battery or its internal sensing chip. It also smells of a simple firmware/software problem. Both of these problems should be able to be overcome, IF, indeed theseare the causes...

When did you guys buy yourD80's....

What are the serial numbers of them...

What version of firmwarehas you D80 have...

Do the batteries have dates or serials on them...

Get together and share some knowledge and try to get something in common so you can get a picture of the root cause...

I hope we ALL find an answer or at least a work-around to this problem...
Nick-On is offline   Reply With Quote
Old May 16, 2007, 12:09 AM   #10
TexasHillbilly's Avatar
Join Date: Jun 2006
Posts: 62

I also read that 3rd party batterys would not work in the D80, but i took a chance and got a 2000mah battery on ebay and it works great.

I can actually tell that i am getting a few 100 pics more from it than i do the nikon one.

So who ever thought up the stupid crap about the chip dont know what they are talking about

Here is a link to a similar battery that I got and from the same seller


SO bid on it and use it it works great for me

I have noticed also that the battery status is not correct sometimes but it is not a problem for me, since i have an extra one. when one goes dead I replace it and keep on shooting.

TexasHillbilly is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:07 AM.