Go Back   Steve's Digicams Forums > Digital SLR and Interchangeable Lens Cameras > Nikon dSLR

Thread Tools Search this Thread
Old Aug 21, 2007, 6:48 PM   #1
Senior Member
Join Date: Feb 2007
Posts: 195

In the past I have been an advocate of using replcement batteries for my (or any for that matter) digital camera. I mean if you can buy an equivalent battery for half the price which meets the manufacturers spec, why not..???

In the last 3 days though I have ripped my hair out trying to sort out a problem with my batteries...

Camera = Nikon D80 with MB-D80 twin battery Grip

Charger = MH-18a

Batteries = Genuine EN-EL3E and replacements are marked as For Nikon EN-EL3E


Until last Sunday, all had been going well. I had been using the replacement batteries for about3 months now, no signs of abnormailty or problems. I left the two genuine units in my camera bag as emergency backups. I enjoyed a good outing on Saturday taking many shots and thought I had plenty of power left in the battery in use so I didn't charge it up. BUT,, I thought I had best charge up the now non-used genuine batteries, just to keep them topped up, so I did, one straight after the other. No apparent problems. Sunday, I went out and on my way in the car I checked out battery life from the menu.

Left battery - 0%

Right battery - 100%

Oh, ok.. The 100 % battery will still last all day so no real hassles here. It was a good day for taking pictures. When I got home, I checked again. Right battery was now down to 87%, so I charged it up first. I stuck it in the charger and went away and came back about half an hour later and saw the LED had stopped blinking which meant full charge had been reached, so I took it out and put in the dead flat battery and again walked away. Now here's where it gets interesting... About 15 minutes later I was kind of busting for the rest room so I went, passing the charger and I looked down at it and noticed that LED was not blinking... Hmmmm, I could have sworn that I put this on only about 15 mins ago.. I did...!!!

I took out the battery and put both of them into the camera. One was 100% and the other was 20% charged. Strange, so I put that one back in the charger. I decided to put the genuinebatteries back inthe camera.One was 100% and the other was 91%.

Strange - What is going on here...???

I checked the charger almost straight away and again noticed that the LED was not blinking so took the battery out and put it straight back in only to see the LED blink about 20 times then stop. I then got the genuine 91% battery and put it in the charger. Same thing, blinked a few times then stopped. Still 91%... I borrowed my brothers identical charger, thinking mine was faulty. It did exactly the same thing with both batteries. We then got one of his EN-EL3E batteries which needed charging and put it into his charger. Away it went blinking for the next half an hour, normal, so I took that battery out and put it in my charger. Again, it blinked for a few times then stopped.. Very strange goings on here...

Conclusion- My battery chargermust befaulty but why did his charger give the same result with my battery. Maybe both my charger and a couple of batteries are faulty... This was puzzling.. I couldn't come to a water tight conclusion as to what was actually at fault as I was getting mixed results.. Too mixed...!!!

Action- Phoned camera shop and asked for twonew EN-EL3E's and a new MH-18a charger. Not cheap but guaranteed to know I have got all bases covered. Also, I would NOT use the replacement batteries any more. Next day I went over to the camera shop and took the charger, the 91% EN-EL3E battery and the replacements.The guy I spoke toputmy EN-EL3E in my chargerand plugged it in to observe. It appeared to charge up normally,, with me in the background saying it will stop any second now but it didn't. Talk about Murphy's Law... We left it on for about 10 minutes and all seemeed to be "normal"... Ok, I took out the genuine battery and put in the 20% charged replacement. Ahhh, this one blinked a couple of times then stopped. I explained that this is what it was doing with the genuine one too last night but couldn't fathom out why it was ok now... We were both stumped...

Epilogue - Used the genuine battery for a day to flatten as much as I could. Took it out and charged. Charged up as per normal. Now both at 100%. I also bought a generic universal battery charger and decided to charge the replacements in this one. One charged up and the charger indicated successful 100% charge,, then the other went from 20% up to 43% after 3 hours in the charger but indicated as fully charged by the analizer within the charger. I put the battery back in and left it on for another 8 hours as the charger goes into a trickle charge once full charge is reached. Have not as yet put them back in the camera to see what state they are in, as I want to fully monitor the genuine EN-EL3E's for one complete cycle, so the replacements can wait.

Final thoughts - Whatever it was, I suspect the replacement batteries may have had something to do with it as they were the only constant source of seemingly trouble.

I will NOT use them again,, and may have to swallow my words about replacements... I just hope all has returned to "NORMAL"...!!!
fewpics is offline   Reply With Quote
Sponsored Links
Old Aug 21, 2007, 11:46 PM   #2
TexasHillbilly's Avatar
Join Date: Jun 2006
Posts: 62

I had a cheap replacement batter and when i used it the camera indicator did not work correctly, but I got as much time out of it as the Nikon one.

I read there was a chip in the Nikon one that make the D80 read the state of it, so i did not ever worry about it. I just used it and used it and never had any problems with it until about a month ago I was carrying it in my pocket and when i got ready to use it I put it in the camera and nothing.

I got a battery indicator on the top display that was blinking, I took it out and recharged it again over night and put it back in and the same thing. So i figured i had shorted it out in my pocket maybe by it hitting some change or my keys and theew it away and ordered a new Nikon geniune one.

I figured that from now on whenI carry a spare battery with me that I will use the little plastic thing that the battery is on and that may avoid such future incidents.

I actually figure the same thing could have happened to the Nikon battery and it was no fault of the replacement that is got shorted out. I am not sure that is what happeend but I assumed it is and could be. SoI just got a new NIKON one now and will be more careful

But you said you were checking the battery level in the D80 of the replacement and I know for sure that you will get weird readings on a replacement from the camera, but the camera will keep on operating for as long or longer than the genunine one. the replacement I had was a 1900 mah one and i know whenI first got it that it would outlast the Nikon quite a big, but it always give me weird readings in the camera.'

Good luck and the best thing any Nikon person can do is stick with pure Nikon products even in lens too

my2cents worth

TexasHillbilly is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

All times are GMT -5. The time now is 10:08 AM.